trouble using work laptop at home

I recently started a new job in which each employee is given a wireless laptop (winxp pro sp2).  At work, the laptop is connected to the internet/lan via a regular Cat5 cable (not wireless).

At home I currently have a small network consisting of two PCs and one laptop(winxp home sp2) with a linksys wireless-g router.  The Pcs are connected via cat5 cable and the laptop is used wirelessly using WEP encryption.  I have no problems with any of these systems.

Now for the problem.  I brought my work laptop home, booted it up, and it immediately found my network.  I connected (using my WEP keys ofcourse).  Great.  However, when I opened a browser I couldn't connect to any websites.  Then I noticed that the wireless connection had bubble with the message, "This connection has limited or no connectivity. You might not be able to access the Internet or some network resources. " 

When I did the ipconfig it seemed that instead of getting a proper Ip (192.168...) it was getting an autoip (169....).  Note that all of my home computers are getting the proper IPs.  I decided to forget the wireless thing and connect the work laptop via cable.  I plugged it in and rebooted and got the same wireless  problems (which i expected).  IPconfig showed that the wired connection had been assigned the proper IP but I still could not connect to the Internet.

I checked my router's dhcp table and it listed the laptop with a valid IP.  However, if I tried to reach the router via a browser from the laptop, it could not connect but if I pinged the routers address (192.168.1.1) through the command prompt it worked.

My work laptop uses the windows xp firewall (so does my home laptop) and an antivirus program.  I have shut both down while trying to connect and no luck.

I found this article http://www.pchell.com/support/limitedconnectivity.shtml but I am not sure if this is supposed to affect my wired connection as well.

Please help.  Thanks.
magicxyzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gavin_wickensCommented:
Have you tried statically assigning your wireless card and see if you can then connect OK?
0
AutoSpongeCommented:
That 169... address means you're not connected at all.  This is a problem between the laptop and the wireless router.  Make sure that the router isn't in g-only mode or some other such setting that could cause the two not to communicate properly.  Check the advanced settings on the laptop's NIC as well.  Is the NIC centrino or a PCMCIA NIC?
0
magicxyzAuthor Commented:
I have tried assigning the IP statcially.  I still couldn't connect.

The network card is Dell Wireless WLAN 1350 WLAN Mini-PCI Card.

I have checked every setting I can on the laptop and on my router and nothing I see is out of place.

Don't forget that I couldn't connect using a network cable either.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

AutoSpongeCommented:
Make sure MAC filtering isn't on.
0
magicxyzAuthor Commented:
MAC filtering is disabled.
0
Fatal_ExceptionSystems EngineerCommented:
Do an ipconfig /all and post it here for us to inspect.  Lets work on the wired connection (connect with the CAT5 port) and take the wifi out of the loop.  You can push the ipconfig /all to a text file, open it with Notepad, and then copy it.

ipconfig /all > ip.txt

FE
0
sunray_2003Commented:
magicxyz ,

I would agree with FE in trying to solve the issue with wired connection first. Make sure your ethernet cable is good.

169 address means there is an issue with your DHCP server not being able to assign a proper IP to your machine. Checking with Static would prove something here.
Just connect the ethernet cable , restart your computer and it should assign IP (just like that). most of the time it is as simple as that . Otherwise go to command prompt and give
ipconfig /release
followed by
ipconfig /renew  and see if you get a proper IP.

At your office do you use any kind of proxy server .. go to IE (assuming that is what you use at both home and office) , tools > internet options > connections > LAN settings .. If there is any settings there that you might need in your office , then note them down , remove them and see if all would be fine.

Alternatively, check with a different browser to see how it goes.

0
sunray_2003Commented:
Did you run that winsockfix that you checked in that article. I would think that is an extreme step as of now but that might solve the issue. With Sp2 on my laptop and both wired and wireless ,everything has been fine . So donot see a need for it since it is working for you fine.

Also before restarting your office laptop , go to start > run > msconfig
disable all applications in the startup tab except the ones related to your anti-virus. Sometimes programs that start during bootup might affect internet connections. Make sure you are disabling the ones that you absolutely feel not necessary.

0
magicxyzAuthor Commented:
Thanks for all of your suggestions.

The problems seems to be solved now, but I am not certain what I did to fix it.

I installed the patch that I mentioned in my first post but I still had the problem.  I disabled a few vmware network connections that were set up on the laptop, played around for a bit more and the wired started working, then the wireless.  I can't tell for sure what the problem was.

0
sunray_2003Commented:
Now it is time for you to take your laptop to work and see everything is fine.
If it works without doing any adjustments , you are lucky. If not , it would be better as you can understand the issue more and know what to do .

Then bring the laptop back home and test it . Trust me that is the only way you can be sure that your issues are gone..

If everything is fine , report back here and close the question

SR
0
magicxyzAuthor Commented:
Everything seems fine at work as well.
0
moduloCommented:
Closed, 500 points refunded.

modulo
Community Support Moderator
Experts Exchange
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.