Setting up an Email Server

I am trying to setup my Mail Server.

2 DNS Servers
name.myhostname.com (Primary)
mail.myhostname.com (Secondary)

Two users pop and imap

I can send/recieve an email from/to
imap@mail.myhostname.com
pop@mail.myhostname.com

however,how would I go about setting it up so it works for
imap@myhostname.com
pop@myhostname.com

 
LVL 13
Dmitri FarafontovLinux Systems AdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Hi,

  Add MX record into your DNS servers :

--BIND DNS ---------------------
myhostname.com
...
   MX 10 mail.myhostname.com    <====
----------------------
Wesly
0
Dmitri FarafontovLinux Systems AdminAuthor Commented:
That entry is already in the DNS Server. Anything else I can try?
0
wesly_chenCommented:
Change the mail server (sendmail ?) config of your server to "masquerade" as its domain.

Wesly
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Dmitri FarafontovLinux Systems AdminAuthor Commented:
I use Postfix as my MTA.
0
wesly_chenCommented:
/etc/postfix/main.cf:
    masquerade_domains = mail.myhostname.com myhostname.com

For more details, please check:
http://www.postfix.org/ADDRESS_REWRITING_README.html

Wesly
0
Dmitri FarafontovLinux Systems AdminAuthor Commented:
Email does arrive with proper headers like:
imap@myhostname.com
pop@myhostname.com

However, when I send it I still need to type
pop@mail.myhostname.com
imap@mail.myhostname.com

How would I fix it to be   a Global Setting for all the users. Someone told that DNS would be enough, but however its not working out ways I want it to be.


0
wesly_chenCommented:
> However, when I send it I still need to type
> pop@mail.myhostname.com

On the machine you send email,
If it is a Windows machines, then bring the comand prompt (cmd) and do
c:\> nslookup
> set q=mx
> myhostname.com  <=== put your hostname
What's the result?

If it is a Linux box, then do
# host -t mx myhostname.com  <=== put your hostname

What's the result?

Wesly

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.