proFTPd having password troubles

I have a simple linux server with apache and proftpd installed to server up a web page.  Everything worked great until the day I forgot my passwords.  Instead of reloading linux I put in the install disk, went to recovery mode, and changed the root password.  I rebooted, logged in, changed the passwords, but now I can't ftp into the machine.  I have tried using passwd to change the password with no luck.

Any suggestions on why proftpd will not take this new password?
DavidBonfoeyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mrielfCommented:
Maybe your ProFTPD configured to not use /etc/passwd file for authentication...
If you authenticate users againt other user file, then you must change user pasword with ftpasswd tool.


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wesly_chenCommented:
Hi,

   You might want to check /etc/proftpd.conf or /usr/local/etc/proftpd.conf for
"AuthUserFile" and "AuthGroupFile" directives. Those 2 directives tell you which password file you use for proftpd.
Besides, if you use password file for authentication, please make sure "AuthPAMAuthoritive" is off.

Wesly
0
Nemesis-ServicesCommented:
what does your /var/log/secure /var/log/messages /var/log/xferlog have in it, when you try and ftp in.

also is it only the root account that you can't ftp in as, or have you tried creating / used another linux account and see what happens.
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

DavidBonfoeyAuthor Commented:
mrielf:
I do not have a ftpasswd utility

Wesly Chen:
I have set "AuthUserFile /etc/passwd" and "AuthGroupFile /etc/group" and still no luck.  AuthPAMAuthoritive was already off.

Nemesis Services:
The secure log is blank.  The xferlog has all the transfers from when I was able to successfully log in.  I have tried creating a new user and still no luck.  I have tried logging in as root (with "RootLogin on") and still no luck.

0
wesly_chenCommented:
> I have set "AuthUserFile /etc/passwd" and "AuthGroupFile /etc/group" and still no luck
What's your original/default setting?
0
Nemesis-ServicesCommented:
can you post your proftpd.conf and also the operating system your using it on, and also the version of proftpd thanks :)
0
mrielfCommented:
> I have set "AuthUserFile /etc/passwd" and "AuthGroupFile /etc/group" and still no luck

If you using shadow passwords on your sytem, then it won't work...

Simply delete or comment out "AuthUserFile" and "AuthGroupFile" lines...
0
DavidBonfoeyAuthor Commented:
The OS is Linux Mandrake 9.2, I am not using kde, gnome or x windows, just a terminal.  I tried deleting the authuserfile and authgroupfile (which is the original method) and still no luck.

Here is the proftpd.conf file:

ServerName             "my Server"
ServerType              standalone
DefaultServer           on
AllowStoreRestart     on
Port                         21
Umask                     022
MaxInstances           30
User                        nobody
Group                      nobody
<Directory />
    AllowOverwrite     on
</Directory>
AuthPAMAuthoritative off
UseFtpUsers              off
RootLogin                  on



0
Nemesis-ServicesCommented:
I've supplied a full proftpd.conf for your pleasure, let me know if it works: :)
then restart proftpd daemon

# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                      "FTP Server"
ServerType                     standalone
DefaultServer                   on

# Port 21 is the standard FTP port.
Port                            21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances                    30

# Set the user and group that the server normally runs at.
User                            nobody
Group                           nobody

# Normally, we want files to be overwriteable.
<Directory /*>
  AllowOverwrite                on
</Directory>

# A basic anonymous configuration, no upload directories.
<Anonymous ~ftp>
  User                          ftp
  Group                         ftp
  # We want clients to be able to login with "anonymous" as well as "ftp"
  UserAlias                     anonymous ftp

  # Limit the maximum number of anonymous logins
  MaxClients                    10

  # We want 'welcome.msg' displayed at login, and '.message' displayed
  # in each newly chdired directory.
  DisplayLogin                  welcome.msg
  DisplayFirstChdir             .message

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE>
    DenyAll
  </Limit>
0
Nemesis-ServicesCommented:
Venabili,

Perhaps the points could be shared between the experts in here ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Security

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.