Service Pack 2 killed my wireless...

Service Pack 2 killed my wireless...

After installing SP2 for XP I can no longer connect to my wireless network.

I turned off the firewall after and rebooted.  Still no connectivity.

When I uninstall SP2 all is well again and I can connect fine, so I know there is nothing wrong with the router.

Any Ideas?

Thanks,
Weller0123Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunray_2003Commented:
Try to upgrade the firmware of the router and check ..

do u have internal wireless card or external wireless card ?

Try to turn off inbuilt windows firewall and check ..

once installing Sp2 and if u have external wireless card, is windows recognising the wireless card..

are you not getting only an ip address through the wireless card ?
0
sunray_2003Commented:
Do you know having SP2 , can you connect to internet through the router using a wired connection ?

0
sunray_2003Commented:
If with Sp2 , your wired connection works , confirm from the manufacturer of ur wireless card that it is compatible with sp2 or check their website and see if they have any updates for sp2
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Snidley_WhiplashCommented:
Did you used to use a program other than XP to control your wireless settings?  I have seen where a computer that pre-SP2 used the DLink Wireless Configuration Utility and after installing SP2 Windows took over the control of the wireless settings and since Windows was never given the settings it was unable to connect.  There are 2 solutions, first go to Start - Control Panel - Network Connections.  Right click on your wireless network connection and choose Properties.  Now select the Wireless Networks at the top and uncheck the box that says "Use Windows to configure my wireless network settings."  Or if you prefer let Windows control the wireless and just click Add... on the same page in the first solution and provide the wireless settings.
0
computerguy801Commented:
Download the newest Configuration Utility for your wireless card (e.g. Linksys or DLink Wireless Configuration Utility). Uncheck "Use windows to configure my wireless settings" and tell the utility to configure the settings.

This is exactly what happened on my laptop after I installed SP2.
0
da_dj_of_soundCommented:
Hey there!...simply reload the Configuration Utility that came with your router AFTER updating to Windows XP SP2. Now when you install, please uncheck "Use windows to configure my wireless settings" and enetr the previous values into the router's utility to configure the settings...Always works...had a similar problem, being the DB manager and the IT guy here at work, simply disabled the built in Wireless configuration in XP from the control panel and ran the previous configuration utility...Post back if anything...Cheers!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Weller0123Author Commented:
The root of this problem was that windows was controling my wireless connection.

For some reason with SP2, windows is now unable to handle the wireless card.  I'm using the Dlink configuration utility now and it seems that my connection speed is highly improved.

Thanks,

Mike
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.