Mapped Network Drives Disconnect and Unable to remap

I'm the administrator of our small network.

Our computers run extremely slow and the mapped network drives constantly disconnect themselves and I 'm unable to remapped them.

I log on to the domain as the user of the computer, I try to map the drive and I get this error.

The user name you typed is the same as the user name you logged in with, that uswer name has been tried.  A domain Controller cannot be found to verify that user name.

I do that a couple of times and then I try to map the drive through my network places and sometimes it will them map and sometimes it won't.

I have that same problem with my administrator account.

Any Ideas how to fix this?  We are using a linksys router for our 50 computer network which is feel is way too small could this be causing it?  Could it be the way activity directory was set up?

Thanks for the help
WestonGroupAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

abu_deepCommented:
Verify the power options on the two nics. If there are cofigured to be shut down, disable that option.
and Check the LAN AutoDisconnect setting on the server:
LAN AutoDisconnect Win2K
http://www.winguides.com/registry/display.php/194/

and u will never be disconnected

0
WestonGroupAuthor Commented:
That didn't work....

Let me re-explain maybe that will help.  I'm the administrator, I have administrator rights.  each day I come in when people on the network log in they get an error message saying unable to reconnect to network drives.   now after a lot of re-trying I finally get them reconnected.

A lot of the times I disconnect and then when I try to reconnect it asks for user name and password.  Then I get an error The user name you typed is the same as the user name you logged in with, that uswer name has been tried.  A domain Controller cannot be found to verify that user name.

I shut down and re-try a bunch of times and finially sometimes it works but sometimes it doesn't work.

If I shut down and and try to log onto there computer as the admin it saying domain unavailable, but when they log on its available.

Its all very strange.

Thanks
0
luv2smileCommented:
What OS is your domain controller? Do you have dns setup correctly on your DC?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

WestonGroupAuthor Commented:
Windows 2000 Server
I'm not sure if DNS is setup correctly


ip 192.168.0.3
default gateway 192.168.0.1
preferred DNS 192.168.0.3
Alternate DNS 192.168.0.2

computer name server.weston
domain weston

I created forward and reverse lookups
standard primary
name = weston
            weston.dns
primary server = server.weston.
responsible person = admin.weston.

name server = server.weston 192.168.0.3

allow zone transfers to any server

main dns server is listening on all ip addresses
enabled forwarders to ip address 4.2.2.2

(did i set this up correctly)

I do a nslookup and get this error
can't find server name for address 192.168.0.3: non-existent domain
can't find server name for address 192.168.0.2: no response from server

default servers are not available
default server: unknown
address: 192.168.0.3

if I do a ls weston

ls weston
[unknown]
weston.        NS        server = server.weston
server          A          192.168.0.3


My internet works for now, but i'm having email problems getting errors unable to biind to dns of destination....

If I do a netdiag /v I get a dns error  (DNS entries for this DC are not registered correctly on DNS server 192.168.0.3)
no DNS servers have the DNS records for this DC registered


Thats the whole problem and all the setting I have currently....Any help would be greatly appreciated
Thanks
0
abu_deepCommented:
Assuming your DC is running DNS, the following settings are correct: On your DC/DNS, and on all of your domain members, make sure the DC's address *only* is listed in the TCP/IP properties (be that via DHCP or static; do NOT use 127.0.0.1 on the DNS itself!). That makes sure your internal lookups work correctly.
For internet access, delete the root zone (if present; it's the single dot: ".") on your DNS in your forward lookup zones. Then open the properties page of your DNS server and configure forwarders to point to your ISP's DNS. The forwarders section is the *only* entry in your network where your ISP's DNS should be listed.

Frequently Asked Questions About Windows 2000 DNS and Windows Server 2003 DNS
http://support.microsoft.com/?kbid=291382

Best practices for DNS client settings in Windows 2000 Server and in Windows Server 2003
http://support.microsoft.com/?kbid=825036

HOW TO: Troubleshoot DNS Name Resolution on the Internet in Windows 2000
http://support.microsoft.com/?kbid=316341

HOW TO: Configure DNS for Internet Access in Windows 2000
http://support.microsoft.com/?kbid=300202

Setting Up the Domain Name System for Active Directory
http://support.microsoft.com/?kbid=237675

Troubleshooting Common Active Directory Setup Issues in Windows 2000
http://support.microsoft.com/?kbid=260371

How to Verify the Creation of SRV Records for a Domain Controller
http://support.microsoft.com/?kbid=241515

How Domain Controllers Are Located in Windows
http://support.microsoft.com/?kbid=247811

How Domain Controllers Are Located in Windows XP
http://support.microsoft.com/?kbid=314861

and thanks for oBdA  whom I copy / past this from...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fettigcj07Commented:
Is this still current or no?
0
WestonGroupAuthor Commented:
Yes this is still current, every so offer the drives of client computers disconnect and I am unable to remap them.  I think its a set up issue with active directory/DNS and our small router

but so father nothing has worked to fix the problem above.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.