[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1034
  • Last Modified:

Never-Build package 'vcl' must be recompiled

Help - I just put Delphi 7 onto XP and am trying to install some components I keep getting an error message "Never-Build package 'vcl' must be recompiled" how do I solve this ?

David
0
DavidBirch2dotCom
Asked:
DavidBirch2dotCom
  • 4
  • 2
1 Solution
 
DavidBirch2dotComAuthor Commented:
someone please comment!
0
 
Wim ten BrinkCommented:
Did you just copy&paste it or did you do a new installation? You can't just copy Delphi just like that...

And maybe those components are compiled with a slightly different Delphi verson. Did you install all the Delphi 7 patches? Do you have the source of those components? If so, rebuild them.
0
 
DavidBirch2dotComAuthor Commented:
I installed Delphi properly onto XP, I then copied *my*  components folder  (not part of delphi or anything, just where i extract all new components to before installing) from my old PC and tried to install from that ... I have checked that the copied files are not read only ...

David
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
DavidBirch2dotComAuthor Commented:
> And maybe those components are compiled with a slightly different Delphi verson. Did you install all the Delphi 7 patches?
I couldnt get the registration to work on 98 so I never installed the patches, I have registered now on XP but havnt installed any patches yet...

> Do you have the source of those components? If so, rebuild them.
yes I have the source, however I get the same error message building or compiling them ...


David
0
 
Wim ten BrinkCommented:
And what if you delete ALL compiled units from those custom packages? Not the ones in the Delphi libraries but in your own component library? It could be that it doesn't want to rebuild one of those units for whatever reason. (Most likely because it can't find the related source file.) Then, once the compiled units have been removed, try to rebuild them.
0
 
DavidBirch2dotComAuthor Commented:
ALL FIXED :)

I installed the Delphi 7.1 patch and it works excellently

For anyone else having this problem - install the Delphi 7.1 patch in order to get Delphi to work on Xp-Pro

David
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now