Never-Build package 'vcl' must be recompiled

Help - I just put Delphi 7 onto XP and am trying to install some components I keep getting an error message "Never-Build package 'vcl' must be recompiled" how do I solve this ?

David
LVL 7
DavidBirch2dotComAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DavidBirch2dotComAuthor Commented:
someone please comment!
0
Wim ten BrinkSelf-employed developerCommented:
Did you just copy&paste it or did you do a new installation? You can't just copy Delphi just like that...

And maybe those components are compiled with a slightly different Delphi verson. Did you install all the Delphi 7 patches? Do you have the source of those components? If so, rebuild them.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DavidBirch2dotComAuthor Commented:
I installed Delphi properly onto XP, I then copied *my*  components folder  (not part of delphi or anything, just where i extract all new components to before installing) from my old PC and tried to install from that ... I have checked that the copied files are not read only ...

David
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

DavidBirch2dotComAuthor Commented:
> And maybe those components are compiled with a slightly different Delphi verson. Did you install all the Delphi 7 patches?
I couldnt get the registration to work on 98 so I never installed the patches, I have registered now on XP but havnt installed any patches yet...

> Do you have the source of those components? If so, rebuild them.
yes I have the source, however I get the same error message building or compiling them ...


David
0
Wim ten BrinkSelf-employed developerCommented:
And what if you delete ALL compiled units from those custom packages? Not the ones in the Delphi libraries but in your own component library? It could be that it doesn't want to rebuild one of those units for whatever reason. (Most likely because it can't find the related source file.) Then, once the compiled units have been removed, try to rebuild them.
0
DavidBirch2dotComAuthor Commented:
ALL FIXED :)

I installed the Delphi 7.1 patch and it works excellently

For anyone else having this problem - install the Delphi 7.1 patch in order to get Delphi to work on Xp-Pro

David
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.