Linux DHCP question

How do I correctly configure my linix anaconda-ks.cfg file so that it tries to acquire a ip address from my router via dhcp????????

Just to give an idea - it looks like this:


netrowk --device eth0 -- bootproto static --ip 10.10.10.20 --ntmask 255.255.255.0 --gateway 10.10.10.254 --hostname mypc
 
** I am going through a vmware session and I am current getting this from my ipconfig from windows:

PLEASE HELP.
THanks

Ethernet adapter Local Area Connection 2:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.111.1
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet1:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.48.1
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . : Belkin
        IP Address. . . . . . . . . . . . : 192.168.2.3
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.2.1

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Autoconfiguration IP Address. . . : 169.254.27.95
        Subnet Mask . . . . . . . . . . . : 255.255.0.0
        Default Gateway . . . . . . . . . :
pjjcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Hi,

   Assume the IP address, default gateway and DNS server are assigned by DHCP server:

netrowk --device eth0 -- bootproto dhcp --hostname mypc

Wesly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pjjcAuthor Commented:
I tried this and it still does not work - it appears to pick up the same static values from above.

rebooted and checked the file to make sure it was updated and IT WAS.
But the IP address was the same static as above.

I then tried to do an ifup eth0 and it came back with the following:
RTNETLINK answere: file exists

I then tried to do a ifconfig eth0 up  and then check the ip address and the same DAMN static ip address - ANY CLUE?

Thanks

0
wesly_chenCommented:
Hi,

   anaconda-ks.cfg is the system configuration file of your system includes which packages you have installed.
It's for Kickstart installation reference. The setting in there will not affect your IP addressing.

   The IP address is configured in /etc/sysconfig/network-scripts/ifcfg-eth0.
You can use "netconfig" to config eth0 using dhcp. Or change "bootproto=dhcp" in /etc/sysconfig/network-scripts/ifcfg-eth0.

Wesly
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.