• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2751
  • Last Modified:

New install, can't format drive: STOP: 0x000000B8 DPC Routine...

Here's the problem: Installed a new motherboard, so we have to reformat the hard drive apparently. So, I booted off of the Windows XP Pro installation CD, deleted all the current partitions, created a new partition and pressed Enter to "install on this partition"... Here's where my bluescreen of death USUALLY happend...

A wait operation, attach process, or yield was attempted from a DPC routine.

STOP: 0x000000B8 (the rest is all 0's... 0x00000000)

and a bunch of other nonsense about how to supposedly fix it, however most of it doesn't apply because I don't have Windows installed yet!

I still have to fully format the Hard Drive right after partitioning, so sometimes it gets up to 20% in the (quick) format option, then freezes or bluescreen, or just a few percent in normal format option.

I tried changing a few things, such as RAM voltage and speed, no success, maybe I did it wrong though. The proecessor speed seems to be set fine, because it displays that it's an AthlonXP 2800+ on the load up screen. Also, RAM seems to be set right because it says it's running at 400 with latency of 3.

Info below:

I am fixing a computer for my uncle... He said it was randomly shutting down on him, and he brought it into Best Buy's Geek Squad, which sucks, and they said it needed a new motherboard... so going along with that, I found him a new motherboard and installed it with my friend who knows hardware better than I do...Upon trying to install Windows, the error occurs.

Hardware:
Motherboard: KT600 KT6V-LSR MSI MS-7021
Processor: AMD Athlon XP 2800+ "Barton", 333 FSB, 512K Cache Processor
RAM: Kingston ValueRAM Dual Kits 184 Pin 256MBx2 DDR PC-3200 (DDR-400)

Video: ATI Radeon 9600XT 128MB DDR VGA/DVI/TV-out
Hard Drive: Maxtor 80GB 7200RPM IDE HARD DRIVE, Model 6Y080P0

Other info: Hard Drive IS set to master, it's the only hard drive in there, on a ribbon cable, not serial ATA... 2 CD-ROM drives hooked up, one writer/reader CD-ROM drive, and one CD-ROM that just reads.
0
Grymlot
Asked:
Grymlot
  • 4
  • 3
  • 3
  • +3
6 Solutions
 
willcompCommented:
I'm guessing a memory or power supply problem.  Since you have 2 sticks of RAM running at less than rated speed, try installing XP with only 1 stick of RAM installed.  Try one stick then the other.  Select stick in second slot (1 or 2 depending on mobo numbering sequence, some start at 0, some at 1) to try first.

If no luck with memory, try swapping power supply with a known good one.

Memory is prime suspect.

Dalton
0
 
EladlaCommented:
0
 
Rabba367Commented:
Some optical drives (CD-roms) cause this problem with XP - so try this if you have a floppy drive available.  Copy the i386 directory to your hard drive and boot into DOS using a floppy.  If you do not have a floppy drive then obtain a CD that is bootable into DOS and install that way.  Incidentally, in the bios turn off your optical drives when trying to install this way.  If you again get a BSOD - unplug the drives as XP will pick them up and try again.  It should install then.  Lastly before looking for a Hardware problem - try installing 98, ME or 2000 (preferably 98/ME) and try and upgrade.  If 98/ME will not install then definitely it is a hardware problem - but I am thinking it is your optical drives and not anything else.

0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
willcompCommented:
Although there may be another cause, faulty memory will cause your exact symptoms.   Earlier versions of Windows (98 and Me) may install and then start having problems.  Try swapping memory first.
0
 
willcompCommented:
Or run Memtest86.
0
 
bytes00Commented:
hi;

i need a clearer picture.. it triggers when loading / or installing which devices ?

if i'm not mistaken, it's da problem of your IDE cable. i do believe, when installed win2000/98/me dosnt have tht problem, but once u have installed the XP it triggers tht problem rite ?

well, let me guess - u have 1 hard disk and your mother board has 2 IDE channel (primary and secondary) - fill them up with the IDE 40-pin connector cable.

else, if u left empty 1 IDE channel, this problem might occour.

and i more thing, try to disable the CD Writer when u trying to install. load the installer with da 1 - cd reader drives. after succesfully install, u just need to pulg another cd drive.

hope tht helps - john

0
 
rajeev_niceCommented:
Memory remains my prime suspect tooo.. ur mobo us running at 333 Mhz and ur DDR RAM is rated at DDR3200 (400). as suggested, try slower RAM, the dealer should be more than happy to swap ur 400 DDR with 266 or similar..!!

0
 
GrymlotAuthor Commented:
Update:

Right after posting the question, I found yet another thing to try from another forum... Someone said it was there CD-ROM drive causing the same problem...

So, I tried installing XP with the other CD-ROM drive, the burner. I got past partitioning, and even starting installing Windows XP finally!

But, then I had this BSOD a little after it started copying files:

IRQL_NOT_LESS_OR_EQUAL

0x00000000A 0xCDcccc20, 0x00000002, 0x00000001, 0x807EB833

So, those of you who mentioned the CD-ROMs were on the right track, I will give those problems a try first. I already tried some of the RAM ideas of only having one in at a time, and such...

I will post updates later today...
0
 
GrymlotAuthor Commented:
Update:

I experimented with only one CD-ROM drive connected, and it seemed to eliminate one of the BSOD's, but I am still getting the IRQL one listed above, I may have to install off the hard drive as suggested somehow with the I386 directory... :(
0
 
GrymlotAuthor Commented:
Final Update:

Turning off the caching and shadowing options for the memory solved the problem :)

Thanks for everyone's help in solving this problem as fast as possible....

Just a couple extra questions, do you think I can turn the shadowing/caching stuff back on once I have Windows XP installed? Also, both CD-ROM drives plugged in gave me an error too, can I plug them both in after install?? Also, which would you suggest, burner on master, reader on slave, or other way around?
0
 
willcompCommented:
Burner - master
CD ROM - slave

Yes, you should be able to plug both in.
0
 
bytes00Commented:
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 4
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now