Outlook will not open any links within a message -- brings up "locate link browser" window

This question is urgent  -- affecting my ability to do work.

Outlook 2003 will not open any hyperlinks within a message -- it just brings up "locate link browser" window, that is, a local file location dialog box. I noticed this behavior after I downloaded a user-agent extension for Firefox 1.0 -- something that completely screwed up my Firefox installation as well. It may be a coincidence, but it may have something to do with the Firefox entension. I have since removed the Firefox installation, docs, & user settings.  
michaelnorthAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

michaelnorthAuthor Commented:
Update: Not sure what's changed, but now Outlook just freezes when any link within a message is clicked. UGH!
0
sunray_2003Commented:
Now have you make IE or any other browser as default browser so that  the link can be opened in that ?

Also go to my computer --> tools --> folder options --> file types
click on URL:HyperText Transfer Protocol so that it is enabled
click on Advanced
Click on edit
under "Application used to perform action" give this

"C:\Program Files\Internet Explorer\iexplore.exe" -nohome

press OK

Now logoff the machine
log back in and check clicking the hyperlink
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sunray_2003Commented:
Also the links that you might see in email may not be valid hyperlinks.
Try to send yourself an email with http://www.google.com in the body of the message, receive that message and click on it to see how it goes

SR
0
michaelnorthAuthor Commented:
Okay, Sunray, that seems to have resolved the problem. How does something that happen? I don't get it.

I'm using Firefox right now, but I was able to browse to the Firefox .exe file and set it as the default action.
0
sunray_2003Commented:
changing between browsers could have affected that,

always make sure to make the browser youwant the links to open as the default one and cross check going to that file type location what is being set
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.