Locked out of MYSQL and PLESK 7 due to an incorrect allowed host setting in MYSQL on 'admin'

Here's the deal.... I have a default Plesk install at my host provider on *nix. I use Navicat 2004 to connect to my MYSQL DB. Since the deafult admin MYSQL login only allows a login from host 'localhost', I used phpMyadmin to set the allowed 'admin' login host to '*', this change has completly locked my out of EVERYTHING!!! Plesk, phpMYAdmin, Navicat.. EVERYTHING!!! Here are my errors:

Plesk login: Unable to connect to database: saved admin password is incorrect. 0: /usr/local/psa/admin/auto_prepend/auth.php3:2 psaerror(string "Unable to connect to database: saved admin password is incorrect.")

===================================================

phpMyAdmin: phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in config.inc.php and make sure that they correspond to the information given by the administrator of the MySQL server.

Error

MySQL said:
#1045 - Access denied for user: 'admin@localhost' (Using password: YES)

===================================================

I am unable to reboot my server. I know the problem is with the allowed "host" setting. I know the problem lies in how I tried to set the host to allow from '*'. So what I need to do is fix that setting so I can connect again. I am still able to connect via SSH using puTTY. I have root access. I believe I need to edit a mySQL config file to ignore grant tables and restart the mySQL service. I do not know how to do this. I need help, without help I'm sure I'll pay several hundred dollars to pay the support team at my ISP. Please help!!!
LVL 3
blainesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AdrianSRUCommented:
If you start the server with the option:
--skip-grant-tables
you will be able to connect.

You can also put a line into your config file (http://dev.mysql.com/doc/mysql/en/MySQL_Cluster_Config_File.html):
[mysqld]
skip-grant-tables

After you are connected, set the host value for the user to '%'.  '%' is the wildcard character in MySQL.


Hope this helps!

-Adrian
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
blainesAuthor Commented:
How do I start the server with --skip-grant-tables? Or how do I edit the config file. I'm new to *nix.
0
blainesAuthor Commented:
Okay, I figured out how to edit the my.cnf (vi my.cnf) and how to restart MYSQL via SSH (/etc/init.d/mysqld restart). I was unable to modify the allowed host via the "priviledges" in phpmyadmin (it kept returning an "unknown command"), however, I was able to browse to the mysql database and modify the 'admin' user in the 'users' table. It appears everything is working again. Thanks for all your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.