Can't access shared files with laptop.

I am having a problem with sharing files.
I have file sharing set up on my laptop and desktop.
Yesterday, I had everything working fine.  I had three shared folders on my desktop, which my laptop was able to access.
Then, this morning, upon a cold boot of both computers, I find that the MSHome workgroup is not available to my laptop.

I did a laptop system restore, and then the laptop had access to MSHome network

I did a reboot, and now cannot access the MSHome network.

When my laptop has access to MSHome network, I can see the following:
File name, e.g., My Data on RONALD01 (Ronald01)
Comments:  \\Ronald01\my data
Computer: RONALD01 (Ronald01)
Network Location: Local Network

When my laptop does not have  access to MSHome network, I can see the following:
File name, e.g., My Data on RONALD01 (Ronald01)
Comments:  \\Ronald01\my data
Computer:
Network Location: Local Network

Since I can gain access to the MSHome network by restoring my laptop to a time when I had access, the problem seems to have something to do with the settings on my laptop.

I can ping my desktop from my laptop, but cannot access the MSHome network.

What setting on my laptop needs to be tweaked so that my laptop can have access to the MSHome network?

rdavesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rdavesAuthor Commented:
Correction:  I cannot ping my desktop from my laptop.
My system is as follows:  Netgear access point attached to a Direcway 2-way satllite modem.
Desktop and Laptop communicating through wireless to the access point.  Hope this helps.
0
danielrsmithCommented:
Have you checked to make sure that when you rebooted the system that windows did not enable the service pack 2 firewall.  you can check this by going into control panel and seeing if the Security Center appears.  If it does then open it and check your settings.
 
0
rdavesAuthor Commented:
The Security Center does appear.  I have turned the Windows XP Firewall off.  I have also input both computers, my Direcway modem and my Access Point into the trusted zone.
anything else?
0
bmquintasCommented:
Any 3rd party firewalls? Norton,Panda,ZoneAlarm?
Your IP adresses static or DHCP?
What do you get on both machines by ipconfig?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.