Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

SMTP PROBLEM - EXPERTS HELP PLZ

Posted on 2004-11-27
29
Medium Priority
?
1,498 Views
Last Modified: 2010-05-18
hi experts,

I am really stucked and confused if that is possible or not in the current environment.first of all let me tell you about my network and how I am connected to the internet
I am connected to internet thorough cablenet. here are some info u may wish to know.
there are 3 servers!
1-active directory only  (Ip :10.10.1.1
2-firewall (ISA 2000) only(10.10.10.1.3
3-web proxy(ISA 2000) only(10.10.10.1.2

4-my pc...(win2k pro) installed MSPCLNT
( IP Address. . . . . . . . . . . . : 10.10.xx.xx)
 DHCP Server . . . . . . . . . . . : 10.10.1.1
 DNS Servers . . . . . . . . . . . : 10.10.1.1

[forget to mention that they all are on same subnet 255.255.0.0]

now come to IIS(SMTP configuration)
SMTP Configuration
------------------
Access/Authentication

Anonymous access, Basic Authentication, and Windows Security package are SELECTED(checked)

Access/Connection

'All except the list below' is selected and there is no IP ADDRESS added there..... I have also tried selecting only the list below and adding my own ip address there but to no avail

Access/Relay Restrictions

'All Except the list below' is selected and no computer, ip address simply nothing is added..."all all computers which successfully authenticate to relay, regardless of the list above' is also selected [i have tried only the list below and adding my own IP there also


Delivery/Advance

no fully-qualified domain :
no smart host

no tick at all just maximum hop count:15
(I tried putting "smt.net4india.net" in FQDN and "202.71.129.73" in Smarthost without checking anything but to no avail also

Delivery/Outbound Security
"Anonymous access" is selected and no tick on TLS encryption.


LDAP Routing

disabled

Security
Administrator is added

[ not that I m always logged in as administrator and it's the only account created ]



further more

C:\WINNT\system32>nslookup -type=mx sn2b.com
Server:  server1.domainname.local
Address:  10.10.1.1

*** server1.fariya.local can't find sn2b.com: Non-existent domain





telnet ns2.studio2online.net 25

It come back with the following:
220-NS2.STUDIOIIONLINE.COM ESMTP Studio 2 Online Ultimate Mail Server ; Wed, 12
Nov 2003 16:01:02 -0000
220-220-Studio2online Power Mail Server;
220-Sun, 22 Oct 2000 14:32:28
220-*********************************************************************
220-220-* Secure Mail Server
220-220-*
220-220-* All connections are logged!
220-220-* This server employs antivirus and antispam technology
220-220 -*
220-*********************************************************************
220




C:\WINNT\system32>telnet user21.busdsl.jtibs.net 25
Connecting To user21.busdsl.jtibs.net...Could not open a connection to host on p
ort 25 : Connect failed


[ I think server might be down else it should be connect aswell ]



I have also tried
Opening IIS
Properties on SMTP
Click Delivery Tab
Enter somethingnew2buy.com for the masquerade domain
Enter mail.somethingnew2buy.com for the Fully-qualified domain name
Enter [212.19.80.74] for the Smart Host
Tick the box labelled Attempt Direct Delivery before sending to smart host
Click OK
Stop and Start IIS

experts help is really appreciated
Thanks in advance
0
Comment
Question by:imnajam
  • 17
  • 9
27 Comments
 
LVL 37

Expert Comment

by:meverest
ID: 12689221
Hello,

first of all, if you leave the settings for "Access/Connection" & "Access/Relay Restrictions" the way you have shown abbove, you are in serious danger of letting the server become an open relay - and that dspells "B-A-D" ;-)

secondly, You don;t seem to have said what the actual problem is.(?)

Cheers.
0
 
LVL 9

Author Comment

by:imnajam
ID: 12689980
well the actual problem is that I am unable to send mails or you can say mails stuck in queue folder when smarthost is configured otherwise it's in "bad mail" folder .bad .bdr extensions
no matter about the relay n the danger because I dont have a public IP address so others(u) wont be able to connect to my smtp server only my local users with IP of(10.10.x.x) would be able to connect to my server and that would be fine.

Thanks
0
 
LVL 37

Expert Comment

by:meverest
ID: 12690021
ok, then can you clip a few lines from the smtp server log for us to see.

cheers.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 9

Author Comment

by:imnajam
ID: 12690077
Oops sorry that you would have to wait because I see that the service was stopped so I try to start and it say couldn't start "Error 1717: The interface is unknown."
anyways, right now I am going to start from the beginning i.e I am removing IIS and reinstalling it than after few minute I'll post you the log entries.
Thanks for the quick reply
0
 
LVL 9

Author Comment

by:imnajam
ID: 12690082
couldn't start SMTP server
Error 2148321281:

the previous error comes when I was starting WWW service
0
 
LVL 9

Author Comment

by:imnajam
ID: 12690092
in the services snap-in I find that "network dde , network dde dsdm" these services are stopped I start them and then www n smtp they are started now without reinstalling.!!
0
 
LVL 9

Author Comment

by:imnajam
ID: 12690120
now another thing which I just figured out is that when I send mails thorough my asp using CDONT no log file even folder came into existance..
but when I connect thorough telnet localhost and perform (helo, mail from, rcpt to, data, subject, .) commands than the log file is created below is the result of what I get when performing these commands and the log file aswell
(note: from my previously configured smarthost I removed masque. domain and ip but in domain name I put "localhost")

220 localhost Microsoft ESMTP MAIL Service, Version: 5.0.2195.6713 ready at  Sun
, 28 Nov 2004 05:24:06 +0500
503 5.5.2 Send hello first
500 5.3.3 Unrecognized command
250 localhost Hello [127.0.0.1]
250 2.1.0 imnajam@hotmail.com....Sender OK
250 2.1.5 imnajam@hotmail.com
354 Start mail input; end with <CRLF>.<CRLF>
250 2.6.0 <FARIYAPC91HGngxliTU00000007@localhost> Queued mail for delivery


--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
-------------------------------------ex04112805.log-----------------------------
#Software: Microsoft Internet Information Services 5.0
#Version: 1.0
#Date: 2004-11-28 00:20:54
#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2004-11-28 00:20:54 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 HELO - +hotmail.com 250 0 31 16 20 SMTP - - - -
2004-11-28 00:21:00 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 testing - - 500 0 32 7 10 SMTP - - - -
2004-11-28 00:21:04 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 MAIL - +from:imnajam@hotmail.com 250 0 44 29 0 SMTP - - - -
2004-11-28 00:21:08 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 RCPT - +to:imnajam@hotmail.com 250 0 32 27 0 SMTP - - - -
2004-11-28 00:21:15 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 DATA - <mypcre2JXAx3k00000006@abc.xyz> 250 0 120 30 3886 SMTP - - - -
2004-11-28 00:23:23 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 QUIT - hotmail.com 240 150967 58 4 0 SMTP - - - -
2004-11-28 00:23:31 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 HELO - +hotmail.com 250 0 33 16 2264 SMTP - - - -
2004-11-28 00:23:36 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 MAIL - +from:rcpt@testing. 250 0 37 23 0 SMTP - - - -
2004-11-28 00:23:42 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 qui - - 500 0 32 3 0 SMTP - - - -
2004-11-28 00:23:48 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 MAIL - +from:imnajam@hotmail.com 503 0 36 29 0 SMTP - - - -
2004-11-28 00:23:50 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 b - - 500 0 32 2 0 SMTP - - - -
2004-11-28 00:23:56 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 HELO - +hotmail.com 250 0 33 16 2263 SMTP - - - -
2004-11-28 00:24:03 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 MAIL - +from:imnajam@hotmail.com 503 0 36 29 0 SMTP - - - -
2004-11-28 00:24:05 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 QUIT - hotmail.com 240 40238 58 4 0 SMTP - - - -
2004-11-28 00:24:14 127.0.0.1 - SMTPSVC1 mypc 127.0.0.1 0 MAIL - +from:hotmail@yahoo.com 503 0 28 27 10 SMTP - - - -
2004-11-28 00:24:16 127.0.0.1 - SMTPSVC1 mypc 127.0.0.1 0 heo - - 500 0 32 3 0 SMTP - - - -
2004-11-28 00:24:20 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 HELO - +hotmail.com 250 0 33 16 2264 SMTP - - - -
2004-11-28 00:24:21 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 MAIL - +from:imnajam@hotmail.com 250 0 44 29 10 SMTP - - - -
2004-11-28 00:24:26 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 RCPT - +to:imnajam@hotmail.com 250 0 32 27 0 SMTP - - - -
2004-11-28 00:24:35 127.0.0.1 hotmail.com SMTPSVC1 mypc 127.0.0.1 0 DATA - <mypcHGngxliTU00000007@localhost> 250 0 122 31 6159 SMTP - - - -
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

0
 
LVL 9

Author Comment

by:imnajam
ID: 12690128
forget  to mention about the queue folder now.
there are total 7 messages in queue folder 2 sent thorough telnet session and the others thorough my asp file using CDONT.
Thanks..
0
 
LVL 37

Expert Comment

by:meverest
ID: 12691976
Hi,

OK.  You should really be using CDO.Message object instead of cdonts these days as the latter is now deprecated and is not supported under windows 2003 and beyone.

Next, the log snipped supplied does not show any attempt to forward mail to the smart host.

Can you find any mention of any other server than localhost in the log?

Regards.
0
 
LVL 9

Author Comment

by:imnajam
ID: 12693413
well, right now SMARTHOST is not configured. in FQDN ("localhost") is written and the other 2 input boxes remains blank.
beside the coding matter well I have read about that aswell and yes I will be using CDO.message object once my pc start delivering the mail (if the mail sent thorough telnet is received by me than I will switch).

the log file was completely copied and sent to you (except blank lines).
I hope that you have read the case(my network) that how is it working and I am not directly connected to the internet I can use mypc(which I want to run smtp) to surf the net connect to msn yahoo (thorough ms firewall client) ...
I just checked the even log and found an entry of Event 4000 of SMTPSVC and giving it below it may be of some use for you

----------event viewer log---------------
Event Type:      Warning
Event Source:      smtpsvc
Event Category:      None
Event ID:      4000
Date:            11/29/2004
Time:            10:45:24 AM
User:            N/A
Computer:      FARIYAPC91
Description:
Message delivery to the remote domain 'Hotmail.com' failed for the following reason: The remote server did not respond to a connection attempt.
 
Data:
0000: d2 02 04 c0               Ò..À    
-----------------------------------------------


THANKS
0
 
LVL 9

Author Comment

by:imnajam
ID: 12693445
you can take a look at the configuration of delivery n advance deliver tab
http://www.freewebs.com/najam/files/smtp.jpg
you may ask for other snapshot if needed
THANKS again for your help
0
 
LVL 37

Expert Comment

by:meverest
ID: 12694232
right, ok then.  The config is all wrong.

yes, i read your network config description.  It doesn't matter so long as the server is able to deliver to the remote system - which seems to be a part of your problem.

maybe you can clarify by telling me what you are trying to do:  what is "ns2.studio2online.net " and "smt.net4india.net" and "202.71.129.73"?

you keep mentioning all these domains and hosts and addresses and i really have absolutley no understanding of how these things are meant to fit together.

please try to cut the jumble and put some structure into this question.

Regards.
0
 
LVL 9

Author Comment

by:imnajam
ID: 12695508
hello meverest,

actually I was trying to sort out my problem and I actually read the post " http://www.experts-exchange.com/Web/Web_Servers/IIS/Q_20794824.html " where they were suggested to try for sorting out the problem I thought that they might be able to help and I mentioned these to you as what I have tried!
smt.net4india.net sorry mis-type it's smtp.net4india.net I tried to configure smart host just to check if I could send mails but I was not able to do so .!!!
you may ignore them all and we can start from the very beginning or as you wish!.

just to clearify I m not an IIS specialist that's my own personal need to setup mail server(SMTP) for sending mail u can treat me as a lay man in IIS.

Thanks
0
 
LVL 37

Expert Comment

by:meverest
ID: 12701595
OK,

if you want to use a smart host, you need to be sure that you can relay mail via that host at all.

go to your IIS server and from a command shell, try to send an email:

telnet <the host name> 25
mail from: <your email address>
rcpt to: <your email address>
data
test message
.

now if the email shows up in your inbox, enter that smarthost in the IIS config (leave everything else blank) aqnd try send via your mail server.

Regards,  Mike.

 
0
 
LVL 9

Author Comment

by:imnajam
ID: 12703506
hello meverest,

here I am, I telnetted to smtp.net4india.com 25
[220 smtp.net4india.com I will Make U Happy.....if u r smart enough !!  #1 Tue, 30 Nov 2004 13:13:56 +0530]
mail from:anyaddress@net4india.com
[250 <imnajam@net4india.com> is syntactically correct]
rcpt to:myemailaddress@yahoo.com
[250 <emailnajam@yahoo.com> verified]
data
[354 Enter message, ending with "." on a line by itself]
test message
.
[250 OK id=1CZ2im-00060w-00]

and yes I received the mail in my inbox
messages inside [] are the response by server. btw, just to tell you that I can use this mail server to send mails but the address of sender must be @net4india.com else it's prohibited by the administrator to send mail thorough it.


now I configured my advance deliver settings as follows
Fully-qualified domain name : smtp.net4india.com
Smart host:202.71.129.125


now I emptied the queue n bad mail folder. stopped the smtp service and send one email it appears in "PICKUP" folder after I start the service it's in the queue folder and is not showen in my inbox

now an entry in event log(SYSTEM LOG) is generated


Event Type:      Warning
Event Source:      smtpsvc
Event Category:      None
Event ID:      4000
Date:            11/30/2004
Time:            12:50:12 PM
User:            N/A
Computer:      FARIYAPC91
Description:
Message delivery to the remote domain 'net4india.com' failed for the following reason: The remote server did not respond to a connection attempt.
 
Data:
0000: d2 02 04 c0               Ò..À    



thanks
0
 
LVL 37

Expert Comment

by:meverest
ID: 12703754
Hi,

first of all, did you do that telnet test from the *server console*?

secondly, for 'fully qualified domain', that's supposed to be *your* server, not the destination!

put something like 'myserver.mydomain.com' in there, and then for smart host, put "smtp.net4india.com" explicit - ie not an ip address.

0
 
LVL 9

Author Comment

by:imnajam
ID: 12703769
okay I changed fqdn to "mail.localdomain.com" and in smart host "smtp.net4india.com" instead of ip

I don't understand what do u mean by the server console :-s I just click on start ... run ... cmd and than telnet... (I did all these task on the computer running IIS)

thanks
0
 
LVL 9

Author Comment

by:imnajam
ID: 12703787
Event Type:      Information
Event Source:      smtpsvc
Event Category:      None
Event ID:      500
Date:            11/30/2004
Time:            1:50:25 PM
User:            N/A
Computer:      FARIYAPC91
Description:
Virtual Server 1: Smart host name is set to smtp.net4india.com.



Event Type:      Warning
Event Source:      smtpsvc
Event Category:      None
Event ID:      4000
Date:            11/30/2004
Time:            1:28:12 PM
User:            N/A
Computer:      FARIYAPC91
Description:
Message delivery to the remote domain 'net4india.com' failed for the following reason: The remote server did not respond to a connection attempt.
 
Data:
0000: d2 02 04 c0               Ò..À    





these event log is generated in (system log) and now there is no mail in queue folder but three files in bad mail
i.e
003750753083011200400000001.BAD     [3kb]
003750753083011200400000001.BDP     [2kb]
003750753083011200400000001.BDR     [1kb]
0
 
LVL 9

Author Comment

by:imnajam
ID: 12703795
after retrying I get these 2 even log generated

Event Type:      Warning
Event Source:      smtpsvc
Event Category:      None
Event ID:      4000
Date:            11/30/2004
Time:            1:57:22 PM
User:            N/A
Computer:      FARIYAPC91
Description:
Message delivery to the remote domain 'net4india.com' failed for the following reason: Destination server does not exist.
 
Data:
0000: d6 02 04 c0               Ö..À    





Event Type:      Warning
Event Source:      smtpsvc
Event Category:      None
Event ID:      4000
Date:            11/30/2004
Time:            1:57:21 PM
User:            N/A
Computer:      FARIYAPC91
Description:
Message delivery to the remote domain 'yahoo.com' failed for the following reason: Destination server does not exist.
 
Data:
0000: d6 02 04 c0               Ö..À    



also 3 files in bad mail folder .bad .bdp .bdr with different filename(numberS)



0
 
LVL 37

Expert Comment

by:meverest
ID: 12704918
does that server have correct dns?

cheers.
0
 
LVL 9

Author Comment

by:imnajam
ID: 12705186
well, how can I check that?
actually as I told you my network environment 10.10.1.1 is a server which is running A.D DHCP n DNS so in my computer the DNS server is 10.10.1.1
how do I check if it's correct or not? my other applications are working fine like i.e & messengers!
0
 
LVL 37

Expert Comment

by:meverest
ID: 12705231
man, you need "networking 101"

sorry, but i give up.
0
 
LVL 9

Author Comment

by:imnajam
ID: 12705277
:(
why do you give up? what's wrong?
0
 
LVL 9

Author Comment

by:imnajam
ID: 12705320
btw, the DNS server I have on my pc is not connected to the internet!
0
 
LVL 37

Expert Comment

by:meverest
ID: 13380658
>> sorry, but i give up.

that says it all.  i'm sorry, but i can't help this user - he seems to lack some of the very basic understandign required to help me help him.  no offense intended, just that my patience is too thin.

suggest paq or delete with refund.
0
 
LVL 9

Author Comment

by:imnajam
ID: 13400128
Thank you meverest for even trying. I'll also try to come up with some more understanding laters!

delete the question plz
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 13449269
PAQed with points refunded (500)

modulo
Community Support Moderator
0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
Lync server 2013 or Skype for business Backup Service Error ID 4049 – After File Share Migration
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
The Relationships Diagram is a good way to get an overall view of what a database is keeping track of. It is also where relationships are defined. A relationship specifies how two tables connect to each other. As you build tables in Microsoft Ac…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question