cannot get a standard gateway address

Posted on 2004-11-27
Last Modified: 2008-01-09

after some problems with internet (uninstalling / installing internet services, protocol, winsock etc), i have following problem :
i can make no network connection (tried aleady other nic card)

with ipconfig, i get following return:
gateway : nothing

I already ran sfc /scannow

Question by:nobus
    LVL 57

    Expert Comment

    by:Pete Long

    mwans you cannot see whatever is supposed to be leasing you an IP address its a default range the computer uses when it cannot communicate with a DHCP server or DHCP device
    LVL 6

    Expert Comment

    what is your connection to the internet (modem?,router?)
    LVL 91

    Author Comment

    i have it connected to a router, which address i know, but right now, i just want to make a network connection first, between 2 computers via the hub in the router (smc)
    in the network wizard, if i choose this computer connects directly to the internet, i get the response the wizard cannot be completed.
    If i select to connect via another computer, it completes, but i do not get a connection
    OS = XP pro

    PeteLong, how can this be resolved?
    LVL 6

    Expert Comment

    If your router is assigning IP adresses to your machines, maybe it's just a problem with a firewall.
    If the router's DHCP service is disabled, you have to assign static IP adresses to your pc's, let's say you router LAN IP is, you have to assign adresses in the range 192.168.2.x, define the DNS server as, and gateway
    LVL 7

    Accepted Solution

    this may help. quoted from

    Why do I get 169.254.x.x IP?

    Symptom: The Internet Assigned Numbers Authority (IANA) has reserved for Automatic Private IP Addressing. If the computer can't get ip from DHCP, APIPA provides an address that is guaranteed not to conflict with routable addresses.

    Resolutions: 1) Make sure you have good connection.
    2) Check the hardware and settings.
    3) Make sure the DHCP is working.
    4) For the test, you can assign static ip. If static ip works, it is possible DHCP issue. If static ip doesn't work, check the hardware or connection.
    5) WinSock2 stack may be corrupted and need to repair.

    LVL 91

    Author Comment

    i have solved this question by running a fix and i am able to surf the internet.
     however, when i select network connections i get nothing displayed.
    Any thoughts on this?
    LVL 1

    Expert Comment

    I am not sure I understand the problem. can you give more details?
    LVL 91

    Author Comment

    Too late, i format / installed it ....

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to improve team productivity

    Quip adds documents, spreadsheets, and tasklists to your Slack experience
    - Elevate ideas to Quip docs
    - Share Quip docs in Slack
    - Get notified of changes to your docs
    - Available on iOS/Android/Desktop/Web
    - Online/Offline

    BIND is the most widely used Name Server. A Name Server is the one that translates a site name to it's IP address. There is a new bug in BIND (, affecting all versions of BIND 9 from BIND 9.1.0 (inclusive) thro…
    #Citrix #Citrix Netscaler #HTTP Compression #Load Balance
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor ( If you're interested in additional methods for monitoring bandwidt…

    758 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now