WindowsXP Networking - BridgeConnections

there are 3 machines involved in this network

                                                                |--------- Laptop (192.168.0.2, GATEWAY: PC1)
Internet----------PC1(192.168.0.1)------------|
                                                                |----------PC2(192.168.0.3, GATEWAY: PC1)

^^ this is the general layout of the network. I
-PC1 Connects to Laptop via a wireless LAN
-PC1 Connects to PC2 via a Wired LAN
What i want to do is bridge the 2 connections on PC1 so that both the LAPTOP on the wireless network and the PC2 on the wired network can get the internet through PC1, which acts as a gateway for both. I have successfully bridged the connections on PC1 and have gotten bother the laptop and the PC2 connecting with each other through PC1. However when I try to select the network bridge as the connection to share my internet over there is no option in the drop down box, and i get a memory error when windows tries to set it up. Ive reinstalled windows and ran every disc and error checking method i can think of and have come up with nothing. I would appreciate any help any1 can give in regards to this matter.
enigma_b17Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

marcin79Commented:
Connection bridgeing is not the good solution for you, connection bridgeing is used for totally different solution it's kind of "dumb router" (in very simple words)
What i could propose for you:
REMOVE THE BRIDGE
I assume that you have at least 2 network cards on pc1 (lets say card-A(wireless) have an ip 192.168.0.1 and card2(wired) 192.168.1.1) when you set up such configuration you should enable the connection sharing on the pc1 for the internet connection card, later set up ip's for laptop (wireless) as 192.168.0.2 and gateway as 192.168.0.1 and for the pc2(wired) as 192.168.1.2 and gateway 192.168.1.1 and... should be done :)

if not post the exact hardware configuration of pc1 (including every kind of network hardware connected to it)

hope this helps
Marcin
0
enigma_b17Author Commented:
Thanks for the response Marcin, however Im not sure what you mean when you say to enable Internet Connection Sharing on the "Internet Connection Card".  As far as im aware it is only possible to put internet connection sharing over one network connection, so bridging seemed to be the only way to do that.
0
sys38893Commented:
bridge is not a problem. Infact what you've described is correct.
The problem is that you need to share your Internet connection. I'm assuming that there is a modem or some other kind of connection that connects you to the Internet. You need to check the "Allow other users..." item in the ICS settings of that connection. In a way, that is the connection that you share, of course through the bridge but that is the way to configure this in Windows XP.
hope it helps,
cc
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

enigma_b17Author Commented:
yea i know about the allow other users to connect setting, I can share the internet connection over one of the networks at the time, ie the wireless or the wired, but i cant share it over both.
0
marcin79Commented:
for me to make it running one of such topology:


                                        192.168.0.1                     192.168.0.2
                                              |----------------------------PC2
                                              |
internet----------------(DSL/LAN)|(PC1)
                                              |
                                              |----------------------------ACCESS POINT )))))))))))))) LAPTOP
                                        192.168.1.1                           192.168.1.2                       192.168.1.3

In this case config of PC1 is:
2network cards + card/device for internet connection
access point uses for laptop connection

second topology is without access point and wi-fi card directly in pc1 (nothing really changes)

and third possible configuration (with or without access point)

                                                                                      192.168.0.2
                                                            /--------------------PC2
                                                          /
internet----------------(DSL/LAN)(PC1)---|192.168.0.1
                                                          \
                                                            \--------------------ACCESS POINT )))))))))))))) LAPTOP
                                                                                        192.168.0.3                       192.168.0.4


in EVERY of above configurations bridge is NOT NEEDED (sys38893 could you describe bridge in your terms ???) the only thing you need is to enable internet connectiong sharing (yes it is "Allow other users...") on pc1 and set up a gateways and dns servers on pc2 and laptop and it should do the trick

by the way are you able to ping pc1 from pc2 if laptop is able to reach the internet ?

Marcin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
enigma_b17Author Commented:
I can click the checkbox for "Allow other users to connect to the internet through this pc", but when I try to save the changes (ie click ok) it says I must choose one of the Network connections to do it over.
0
marcin79Commented:
you have to choose (select) a connection which you use to connect to internet (ie dsl line)

regards
marcin
0
enigma_b17Author Commented:
" you have to choose (select) a connection which you use to connect to internet (ie dsl line)

regards
marcin"

Ya, thats my point. Im trying to share 2 networks on PC1 over the one internet connection, however bridging the connections doesnt allow me to select the network bridge as a means of sharing the internet connection.
0
marcin79Commented:
leave the bridge, remove it completly, follow my instructions and enable internet connection sharing on your internet connection (and only there)

regards
marcin
0
sys38893Commented:
You need to enable ICS only on the connection that you are connectiong to the internet. Not in the ones that connect you to your other networks.

Once you do this you may have the bridge. It helps if you have it because everyone will see you as 192.168.0.1.

                                                                               ____ wireless card (no ip becase in bridge)
                                                                              |
MODEM ---------------------------------XP soft. Bridge-----------wired card (no ip becase in bridge)
IP addres taken from the ISP            192.168.0.1          
ICS enabled

This is my home configuration using XP prof. It works fine for both wireless and wired clients.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.