php and virtual hosts in Apache

I have php4 installed and working on my Apache server for the main site.  I have sense added a site.  php does not seem to be working on that new site since when I view the source I see the php code instead of my parsed php.

Above any <DIRECTORY> information for my main site I have:

LoadModule php4_module        modules/libphp4.so

Here is what the VirtualHost info says about my secondary host:

NameVirtualHost 216.117.175.151
<VirtualHost 216.117.175.151>
DocumentRoot "/www/naabe.com"
ServerName naabe.com
<Directory "/www/naabe.com">
allow from all
#Options +Indexes
    Options Indexes FollowSymLinks ExecCGI
</Directory>
</VirtualHost>

Anyone know what I may have to do to have it start parsing for that second host?

Thanks in advance!
LVL 7
wtconwayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wtconwayAuthor Commented:
sorry for my spelling... I meant to say "I have since added a site"
0
gripeCommented:
Do you have an AddType set up for your php scripts?

    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wtconwayAuthor Commented:
Yes, it is defined above where I have my general options and in my VirtualHost.  It now reads:


<VirtualHost 216.117.175.151>
DocumentRoot "/www/naabe.com"
ServerName naabe.com
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
AddHandler cgi-script .cgi .pl
AddHandler type-map var
<Directory "/www/naabe.com">
allow from all
#Options +Indexes
    Options Indexes FollowSymLinks ExecCGI
</Directory>
</VirtualHost>
0
wtconwayAuthor Commented:
Ok, Sorry.   I actually had a problem in the php page.  For the effort I am awarding gripe the points.

Trav
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.