Hard drive capacity incorrect

I just purchased a Seagate Baracuda 7200.7 Plus (model# ST3120026A) 120 GB hard drive.  The problem is that it is incorrectly showing up as a 31.4 GB drive under Windows XP Pro SP1.  The computer is a Micron Netframe 5200.  The motherboard is an Intel C440GX+.  I purchased the computer new in 2000.  All the drivers and bios files are the latest available.

I have viewed the drive using Seagate software and Ontrack DiskManager and both programs see the drive as 30+ GB.

The bios doesn’t recognize the drive at all.

Does anyone know how I can get Windows XP to see the drive as a 120 GB drive?

Thanks in advance!

David
d_springerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CrazyOneCommented:
Have you updated the BIOS so it will recognize this disk?
0
d_springerAuthor Commented:
FYI - The drive is setup on IDE 1 as master.  There is no  other device attached to IDE 1.
0
CrazyOneCommented:
It kinds of look like you may need to use the Ontrack DiskManager to have this machine see the disk in its full capacity.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

d_springerAuthor Commented:
The bios is the latest version available.
0
d_springerAuthor Commented:
I have used Ontrack DiskManager.  It sees the drive as 33816 MB.  There is no way for me to tell it differently.
0
CrazyOneCommented:
Even though 2000 seems like new technology changes are so fast that 2000 in computer terms is like 10 years behind. Perhaps the BIOS just is not equipped to handle a disk of this size.
0
CrazyOneCommented:
I don't think XP is the problem. Something in machine is the problem. I mean I have two drives that are 120GB+ and XP has no problems seeing them and their full size. Base on what you posted it comes across like the BIOS of your machine isn't seeing the full capacity, if this is the case do not blame the OS blame your BIOS
0
CrazyOneCommented:
Use a controller card like PROMISE that has a seperate BIOS that allows the whole system to see the entire size of the hard disk.
0
CrazyOneCommented:
How to Enable 48-bit Logical Block Addressing Support for ATAPI Disk Drives in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;303013
0
CrazyOneCommented:
Have you enabled "48-bit LBA" in your BIOS?
0
WhitePhantomIT ProfessionalCommented:
The jumper is most likely set to limit the drive's capacity to 32GB, as shown here:

http://www.seagate.com/support/disc/ata/st3120026a.html

WP
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WhitePhantomIT ProfessionalCommented:
I should clarify; just remove the jumper from those pins and the drive's full capacity should show up fine.

WP
0
d_springerAuthor Commented:
48-bit LBA is for drives over 137 GB.  My problem is different.  Yes it is enabled (automatically in Win XP with SP1).
0
CrazyOneCommented:
Yeah but did you enable the BIOS to see to see 48-bit and are the jumbers set as WhitePhantom suggested.
 
0
CrazyOneCommented:
This is a BIOS thing not and XP thing. Make sure your BIOS recognizes disk of this size and make sure the BIOS is set to recognize such a disk size. If not the OS won't see the full size of the disk. If the BIOS doesn't not see it or the Controller card does not recognize then the OS won't either. In other words in your own words some where along the line the machine needs to recognize the the full capcacity of the disk if it does not then OS can't either.
0
CrazyOneCommented:
Did you do what WhitePhantom suggested?
0
Lieven EmbrechtsSenior IT ConsultantCommented:
There's only 1 solution: add a newer controller-card that can handle this.
A second hand ATA-100 card would do the job fine.
0
d_springerAuthor Commented:
WhitePhantom,

I can't believe I was up working on this until 5:00 AM due to a jumper setting :(

CrazyOne thanks for all of your help!

Sincerely,

David (very tired in Baltimore)
www.sovereignfunding.com
0
d_springerAuthor Commented:
CrazyOne,

On your personal details page your link isn't working:

http://crazyone.tekmasters.com/resumespencerschroeder.doc

David
0
WhitePhantomIT ProfessionalCommented:
Sorry you spent so much time on a problem like this...I know how it goes. :-(  Been there many times.  That's really annoying if you received the drive new with the 32GB jumper already set.  The only time I've ever used that setting was when I tried to put a 40GB hard drive into a computer that had a BIOS limited to 32GB.  The drive wasn't recognized until I set the 32GB jumper.

WP
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.