• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 374
  • Last Modified:

setup T1 internet connection for Solaris 9

Hi,
We have another sun Blade 2000 system.
I wanted to connect to the net.

Can you tell me the step by step procedure to connect to the net.
Like I have a T1 connection.
When I connect to windows it connects automatically

How do I do this in solaris

will be waiting for your reply

bye
siddu
0
siddu_jms
Asked:
siddu_jms
  • 3
  • 2
  • 2
2 Solutions
 
wesly_chenCommented:
> Like I have a T1 connection
> I connect to windows it connects automatically
Do you have DHCP server? Assume  you have DHCP server since Windows connects automatically.
As root do "sys-unconfig", then after you boot up from sys-unconfig, choose DHCP for IP address assignment.
For "Name Service", choose "none" if you don't have NIS, NIS+, LDAP, or DNS.

Or you can try the following line as root:
# ifconfig eri0 dhcp   <=== Do "ifconfig -a" to confirm the network interface is "eri0" first

If you don't have DHCP server, then please provide the output from Windows machine:
ipconfig /all
route print

So people can understand your network environment to assist you.

Regards,

Wesly
0
 
yuzhCommented:
If your Sun Blade 2000 use fix IP then follow the instruction in the following page to set it
up:
http:Q_20873468.html


If you want to set it up as a DHCP client, then have a look at the instructions in:
http:Q_21013340.html

also have a look at this "Connecting to Any ISP with Solaris 7 and Solaris 8" (should work for Solaris 9 as well):
http://www.kempston.net/solaris/connectanyisp.html


0
 
siddu_jmsAuthor Commented:
Hi,
When I was setting up the network connection with the sys-unconfig

there was some error

And now it says

Warning : Timed out waiting for NIS to come up.

So can anyone tell me how to get over it and then login and so that i can run sys-unconfig again and setup

One more question: how do I change the hostname?

bye
siddu
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
siddu_jmsAuthor Commented:
Hi,
I am not able to continue with the boot up.
Can anyone help me fast

please

bye
siddu
0
 
yuzhCommented:
Your box was a NIS client, and you don't have a a NIS server, you need to boot up the
box to single user mode, and disable the NIS startup script.

or
Remove the file /etc/defaultdomain

Have a look at the following page for more details:
http:Q_20576878.html
0
 
yuzhCommented:
If you are not using NIS, please make sure that your /etc/nsswitch.conf doesn't have
nis in the file.

boot up the box to single user mode
boot -s

then
cd /etc
cp -p /etc/nsswitch.conf  /etc/nsswitch.conf.old
cp /etc/ nsswitch.dns /etc/nsswitch.conf  
0
 
wesly_chenCommented:
<Wesly>
> For "Name Service", choose "none" if you don't have NIS, NIS+, LDAP, or DNS.
So please make sure 2 things:
1. Do you have DHCP server? (ipconfig /all on Windows will tell you)
2. Do you have NIS server? If yes, the NIS server is in the same subnet or not?
    If not, then you need to know the IP address of NIS server to config your NIS client.

My assumption for you is
1. Yes
2. No.
(please correct me if my assumption is wrong.)

>Warning : Timed out waiting for NIS to come up.
Press "Stop + A" (hold "Stop" key and press "A" key at the same type)
You will get "ok" prompt.
Type in
boot -s
it will reboot into single user mode.

Login as root and type
sys-unconfig
to restart again.
Or do yuzh's suggestion.

Regards,

Wesly
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now