How to change localhost.localdomain in Exchange SMTP Services

Hi,
    When I send out my emails, some email servers recognize my domain as localhost.localdomain. How do I change that setting in MS Exchange SMTP Services?
    Appreciate if you can help.

Eg.

OutboundConnectionResponse SMTPSVC1 - - 220+localhost.localdomain+ESMTP+Sendmail+8.12.8/8.12.8;+Mon,+29+Nov+2004+12:40:43++0800 0 0 -

   Thanx

waiming
waimingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ColinRoydsCommented:
Open ESM , go to recipients / recipients policy / edit the default recipient policy and add in the new domain that you want, set it as default .
This will add the domain in to Exchange
0
ColinRoydsCommented:
How to Manage the Default Recipient Policy
1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
2. Expand the Recipients object, and then double-click Recipient Policies.
3. Right-click Default Policy in the right pane, and then click Properties.

Note that the Filter rules entry defines a single entry of (mailnickname=*) and that in the Filter rules section, the Modify button, and the Remove buttons are shaded. This behavior occurs because the default recipient policy must apply to all recipient objects (that is, all of those objects that have a mail nickname or alias).
4. Click the E-mail Addresses (Policy) tab.

A list of generation rules for e-mail addresses is displayed. Rules exist for SMTP and X.400 addresses. You can edit these rules, but you cannot remove them. For example, if your organization decides to change its e-mail address from ".com" to ".co.us," click the SMTP rule, and then click Edit.  
5. In the Address field, type the new SMTP address, and then click OK.
6. Click OK.

You receive a message that states that you have changed e-mail addresses of SMTP type and you are prompted to update all corresponding e-mail addresses to match the new address format.
7. Either click Yes to update all existing addresses or click No if you do not want to change any existing objects. If you click No, the new SMTP address applies to all newly created recipients.

here is the orginal article
http://support.microsoft.com/kb/319201
0
waimingAuthor Commented:
Hi ColinRoyd,
   Nope it doesn't work. The message was obtained from the SMTP log. Apparently, on the receipient's server, they recognized the email address as coming from localdomain.localhost instead of my domain. Due to this, my mails were rejected from their server.
   Appreciate if you can help.

waiming
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ColinRoydsCommented:
ok, this is slightly different you need to open ESM / Servers / Servername / protocols / SMTP / SMTP Virtual Server / properties / delivery / adavanced / in the masqueard domain put in the proper name that matches your MX records,
this way when mail is sent out it hides behind the name you put here.
Please note this is for Exchange 2003, Exchange 2000 the the first few steps are slightly diff but the rest is the same, still look under protocols / SMTP Virtual Server   / properties / delivery / adavanced

This should sort it out
0
waimingAuthor Commented:
Hi ColinBoyd,
   Tried but didn't work either. The localdomain.localhost is still logged in my SMTP logfile.
   Kidego, any ideas or thoughts on this?

waiming
0
ColinRoydsCommented:
did you restart the smtp virtual server after doing the change?
0
ColinRoydsCommented:
waiming

I am still not convinced this should work have a look here....

http://support.microsoft.com/default.aspx?scid=kb;en-us;314331&sd=tech

"This step-by-step article describes how to specify a masquerade name for a domain. A masquerade domain replaces the .local domain name in any Mail From lines in the message header"

Set the Masquerade Domain Name
1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
2. If administrative groups are enabled, expand the administrative group in which the server that you want to use is located.
3. In the console tree, click Server, expand your server, and then double-click Protocols.
4. Double-click SMTP, right-click the SMTP virtual server that you want to work with, and then click Properties.
5. In the Properties dialog box, on the Delivery tab, click Advanced.
6. In the Advanced Delivery dialog box, in the Masquerade Domain box, type the domain name that should receive any nondelivery reports.  
7. If you want to override the default FQDN, type a new value in the Fully-qualified Domain Name box, and then click Check DNS to ensure that you have entered the correct value and that DNS resolution is configured properly.
8. Click OK, and then click OK again.


Let me know if it still doesn't work
0
waimingAuthor Commented:
Hi ColinRoyd,
   Nope. Doesn't work.
   This is how the SMTP log looks like

<Receipient IP> OutboundConnectionResponse SMTPSVC1 - -  220+localhost.localdomain+ESMTP+Sendmail+8.12.8/8.12.8;+Tue,+30+Nov+2004+00:37:26++0800
<Receipient IP> OutboundConnectionCommand  SMTPSVC1 EHLO  - <Host domain at xxx@xxx.com
<Receipient IP> OutboundConnectionResponse SMTPSVC1 - -  250-localhost.localdomain+Hello+[Host IP],+pleased+to+meet+you
<Receipient IP> OutboundConnectionCommand  SMTPSVC1 MAIL  - FROM:<waiming.yap@xxx.com>
<Receipient IP> OutboundConnectionResponse SMTPSVC1 - -  553+5.1.8+<someuser@xxx.com>...+Domain+of+sender+address+someuser@xxx.com+does+not+exist
<Receipient IP> OutboundConnectionCommand  SMTPSVC1 QUIT  - - 0 0 - -
<Receipient IP> OutboundConnectionResponse SMTPSVC1 - -  221+2.0.0+localhost.localdomain+closing+connection

    Noticed that it resolves my host name and host domain as localhost.localdomain.
   I have set the Masquerade domain and even restarted my server but to no avail. My MX record has been setup correctly. It is able to send mails to other domains except this particular domain. Please help.

waiming
0
ColinRoydsCommented:
Ok there is another way round this, you could contact your ISP and ask them if they have a mail relay you can use most ISP's do, in that case I would create a SMTP connector if you don't have one already and use a forwarder which would then be your ISP's mail relay. That way the final recipients mail server will resolve back to the relay and not your own server, this should sort the issue out. As well as any other issues such as reverse ptr records and so on, if you didn't have one.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.