SQL Server ODBC Error

Help!  I need to connect to a remote SQL Server and I cannot get the ODBC connection working.  I receive the following error message:

Connection failed:
SQLState: '01000'
SQL Server Error: 10060
[Microsoft][ODBC SQL Server Driver][TCP IP Sockets]ConnectionOpen(PreLoginHandshake()).
Connection failed:
SQLState: '08001'
SQL Server Error: 11
[Microsoft][ODBC SQL Server Driver][TCP IP Sockets]General network error. Check your network documentation.

I am behind an ISA 2000 firewall.  Port 1433 is open.

I need this resolved as soon as possible.  I will gladly double the points if someone can help me get this working.  Thanks in advance.
tgerman10Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duane LawrenceCommented:
Also:

1. Check to see if you can ping the server in question.
2. Scan the port from the server to see if it is open, the latest service packs from microsoft have been closing these.
0
Duane LawrenceCommented:
See if you see an error like this in the error logs

SuperSocket Info: Bind failed on TCP port 1129

It means another program has the port.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

tgerman10Author Commented:
duanelawrence,
Thanks for your quick response.  Yes, I can successfully ping the server in question.  I do not have access to the remote SQL Server, therefore I cannot try some of your other recomendations.

This connection worked in the past.  It is just recently that the connection failed.  The only recent change to our network was an upgrade from DSL to a T1.  The T1 router is not blocking any ports though.
0
Duane LawrenceCommented:
Then I would bet it is a router configuration somewhere.  I can not help you with routers, but it is time to get tech support with your T1 provider involved.

evidance
It worked before.
A change happened, install a T1
RESULT: It does not work anymore

0
tgerman10Author Commented:
I was afraid of that...  I was told by the T1 provider that it was not a T1 issue, but I will look into that further.  I will post again when I have more information.  Thanks.
0
Duane LawrenceCommented:
Ask your network admin if he put in any new routers to support the T1.  It could be that router and not the T1 provider.  You need to have your network admin guy involved.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tgerman10Author Commented:
The problem has been fixed.  The remote server was not accepting connections from our new IP.  Thanks for your help.  I appreciate your quick response.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.