Outlook 2003 Encrpyted Email Prompt on Open

One of the computers I work on gets numerous encrypted emails sent to it on a daily basis.   Every time I attempt to open an encrypted message it prompts me to hit "Ok" in response to  the following prompt:
"An application is attempting to access to a Protected Item.
CryptoAPI Private Key"
with the options of "Ok" "Cancel" and "Details".

On another computer  I use, if I hit "Ok" to the above prompt, it never asks me again until I close and reopen outlook.

Both outlook versions are 2003.  
I would like the prompt completely eliminated if possible or at least configured so that I only have to hit "Ok" once (like in the second example above), not every time I open a message.
It would make printing the emails out much less painful in batches.
Any help would be appreciated.  
Thanks for your time.
steveshapAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunray_2003Commented:
I may not have a direct answer but you can try these

a) Make sure both outlook are equally updated

b) Do you have any special add-in or software installed in those machines to read those encrypted emails. If you have then , make sure it is available in both the computers

c) You may want to create a new outlook profile in the machine that has issues , import the PST file and check

SR
0
rindiCommented:
Check your settings in Outlook, particularly the security settings. Also have a look at the settings of IE, if cookies are enabled or not, or if ActiveX elements are on.
0
steveshapAuthor Commented:
Thanks for your replies.

sunray 2003:
I have not had a chance to try a.) and c.) yet but to answer b.) there is no special add-in software installed that I am aware of.  The certificates were provided by Thawte personal email and installed automatically through the browser.

rindi:
I compared the security settings for the web and local intranet zones on both computers to make sure they were identical.  I have checked the outlook security as well but there doesn't appear to be a setting that explicity deals with this.  After opening the email and double clicking the lock symbols I can choose to explicitly trust that certificate but that doesn't seem to help.

Some further details.
Both computers are on the same network.  The computer with issues is windows 2000 and domain controlled with a regular user.
The computer that is fine is windows xp professional, non-domain controlled, with local administrator priveledges logged in.

As far as I know those are the only relevant details.
Thanks again for the replies.
0
steveshapAuthor Commented:
Alright, here is the solution I found.

Go into outlook and select options, click on security tab and select Import/Export undert digital id.
Select the export radio button and select the proper certificate to export.
Create a filename and a password.
Check the 'Delete Digital ID from system' box.

Next double click the exported file, which in my case was located on my desktop.  It will start the import wizard.  Leave 'use strong security' unchecked and check 'make exportable'.  
Now when you open an email, it will open without a prompt.
0
moduloCommented:
Closed, 250 points refunded.

modulo
Community Support Moderator
Experts Exchange
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Security

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.