unable to manipulate oracle table name containing special characters

hey all -
a modeling program (erwin) created this table, which i am currently unable to drop.  i am using dbvisualizer to connect to the db.  the table name is:

DBDB.BIN$6YefzzGY8ingMAB/AQBlXA==$0

trying to kill it:

drop table DBDB.BIN$6YefzzGY8ingMAB/AQBlXA==$0
ORA-00933: SQL command not properly ended

drop table "DBDB.BIN$6YefzzGY8ingMAB/AQBlXA==$0"
ORA-00972: Identifier is too long

drop table 'DBDB.BIN$6YefzzGY8ingMAB/AQBlXA==$0'
drop table '"DBDB.BIN$6YefzzGY8ingMAB/AQBlXA==$0"'
drop table 'DBDB.BIN$6YefzzGY8ingMAB/AQBlXA\=\=$0'
drop table '"DBDB.BIN$6YefzzGY8ingMAB/AQBlXA\=\=$0"'
ORA-00903: invalid table name

i have played with some other things as well.  still can't kill it - any suggestions??  tell me how to kill this thing!!

LVL 2
taveirneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

paquicubaCommented:
SQL> create table "$MAB/AQBlXA==$0" (col1 number);

Table created.

SQL> drop table "$MAB/AQBlXA==$0";

Table dropped.

It worked, I just couldn't use the whole name, got identifier is too long error
0
taveirneAuthor Commented:
i was able to
SELECT DUMMY_FLD  || 'BIN$6YefzzGY8ingMAB/AQBlXA==$0' FROM DBSB.DUMMY_TBL having no problems so it doesn't seem like it is an invalid character in there;

with your query and the one i tried earlier that brings us back to:

drop table "DBDB.BIN$6YefzzGY8ingMAB/AQBlXA==$0"
ORA-00972: Identifier is too long

how can i correct this?  the table name is 30 characters.  i'm not able to view indexes or other information with dbvisualizer, it doesn't seem to be able to execute SQL on the table to populate several of the panes in the application.
0
paquicubaCommented:
You don't need the Schema here:

SQL> create table "BIN$6YefzzGY8ingMAB/AQBlXA==$0"(col1 number);

Table created.

SQL> drop table "BIN$6YefzzGY8ingMAB/AQBlXA==$0";

Table dropped.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

taveirneAuthor Commented:
i get a 942 - table or view does not exist if i try that.  when i log in with the dbvisualizer client i see multiple databases so i believe the DB name is necessary; but it shouldn't be the component the complaint is about is it?
0
legendcainCommented:
drop table DBDB."BIN$6YefzzGY8ingMAB/AQBlXA==$0";


0
taveirneAuthor Commented:
ORA-38301: can not perform DDL/DML over objects in Recycle Bin
0
SMartinHamburgCommented:
this seems to be an already dropped table. Oracle 10 puts it in a recycle bin
try PURGE TABLE DBDB.BIN$6YefzzGY8ingMAB/AQBlXA==$0;
to finally get rid of it.
Or PURGE TABLESPACE <table_space_name>;
to get rid rid of all of them for a table space.
See http://www.oracle.com/technology/pub/articles/10gdba/week5_10gdba.html
as a backgrounder.

Regards
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
legendcainCommented:
oooohhhh... you gotta purge it! :)

silly me, it's a deleted table...

select ORIGINAL_NAME from RECYCLEBIN where OBJECT_NAME='BIN$6YefzzGY8ingMAB/AQBlXA==$0';

then, whatever name that returns to you, perform the following:

purge table [ORIGINAL_NAME];

example:

sqlplus> create table T (X integer);
Table created.
sqlplus> drop table t;
Table dropped.sqlplus> select original_name, object_name from recyclebin;
ORIGINAL_NAME                    OBJECT_NAME
-------------------------------- ------------------------------
T                                BIN$DLsVweqdRDaoyjTfAdfFnA==$0
sqlplus> purge table t;
Table purged.

hope that does the trick
0
pratikroyCommented:
The BIN$... Object is a dropped trigger (it appears to be anyway), that is in the recycle bin, and apparently the drop user statement seems to be having trouble deleting the user with an associated object in the recycle bin.

To try and get around it, try going the web-enable enterprise manager, the administration page, then Tables (or actaully any object), filter for the owner of the object, the the recycle bin button appears. Or, from the sql prompt, you can do a "purge dba_recyclebin;" (to empty the recycle bin for all users, or connect as the user and issue a "purge recyclebin;".

I think this will get around the problem you are experiencing.

0
taveirneAuthor Commented:
i did a select * from recyclebin and got nothing, but what is working for me is

purge table DBDB."funkyname"

thanks guys!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.