(Win XP) Net Send: msg alias not found

Hi there

I would like to be able to use the "net send" command in Windows XP to pop-up messages to clients on my network. (Workgroup, no domain).

When I type: "net view" at a command prompt (as Administrator) I can see a list of all of my clients.
\\STATION01, \\STATION02 and so on. File sharing is NOT enabled, client for Microsoft Networks is. NetBIOS over TCP/IP is enabled.

When I type, "net send STATION01 message", I get the following error.

"An error occurred while sending a message to STATION01.

The message alias could not be found on the network.

More help is available by typing NET HELPMSG 2273."

I can't connect to any computers by "Net view \\COMPUTERNAME" because I get an error "System error 53 has occurred. The network path was not found." I assume this is because file and printer sharing is turned off.

I checked the services and the computer browser service cannot be started either. I get the error "The Computer Browser service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service." The Event Log just has 3 Information entries that the service entered the running state then entered the stopped state. No errors.

Is there any way I can use 'net send' to send messages WITHOUT enabling a file/printer share? Thanks!
x13Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
try this
net send * <text of message>
this will send it to all workstations, as a test
0
Top_nerdCommented:
in a command promp(start>run>cmd(enter)), type "ping STATION01" (without the quotes).

if u get something like this:

-----------------------------------------------START---------------------------------------------------------
Pinging STATION01 [XXX.XXX.XXX.XXX] with 32 bytes of data:

Reply from XXX.XXX.XXX.XXX: bytes = 32 time>10ms TTL = 128
Reply from XXX.XXX.XXX.XXX: bytes = 32 time>10ms TTL = 128
Reply from XXX.XXX.XXX.XXX: bytes = 32 time>10ms TTL = 128
Reply from XXX.XXX.XXX.XXX: bytes = 32 time>10ms TTL = 128

Ping statistics for XXX.XXX.XXX.XXX:
   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate roud trip times in milli-seconds:
  Minimum = 0ms, Maximun = 0ms, Average = 0ms
-----------------------------------------------END------------------------------------------------------------
Then the messenger service is probably not running. To start it, go (on all the computers) start>run>services.msc(enter). Go down the list until u arrive to an item called "Messenger". Set the startup type to automatic (right click "Messenger". In the general tab, next to startup type click automatic).
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

crissandCommented:
No.
0
crissandCommented:
If you have XP2 configure Messenger service to startup automatically, by default is disabled.
0
x13Author Commented:
Ok here's what I get:

* net view:
.. some computers ...
\\STATION14
.. some computers ...
The command completed successfully.

* Ping STATION14
Ping request could not find host STATION14. Please check the name and try again.

* Ping \\STATION14
Ping request could not find host \\STATION14. Please check the name and try again.

* Ping 192.168.1.104 (station14's IP address, determined with ipconfig)
Pinging 192.168.1.104 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 192.168.1.104:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

* net send 192.168.1.104 Test message
An error occurred while sending a message to 192.168.1.104.

The message alias could not be found on the network.

More help is available by typing NET HELPMSG 2273."

* The Messenger service was enabled on the computer in question and also on the computer I'm sending from. The Computer Browser service is started on the sending computer but won't start on the receiving one.
0
stevenlewisCommented:
what firewalls are involved? smacks of a firewall issue
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
x13Author Commented:
Wow that was fast. There is a Linux iptables firewall that just controls access between the local network and the ouside world. Windows XP SP2 has a built-in firewall as well, but it doesn't appear to be blocking anything on the sending computer (I can send messages TO this computer (staff-XP) from my computer (win98) and FROM it, just not to the client computers. All have XP SP2.

The only difference I can see, is that the Computer Browser service is running on the computer that works. I checked that the Terminal Services port (3389 I believe) is open on the XP firewall on the non working computer. Should I disable the software firewall completely?
0
stevenlewisCommented:
as a test yes
0
x13Author Commented:
!

You fixed it. Disabling the Windows XP SP2 firewall is allowing the messages to go through!

Thanks very much.
0
x13Author Commented:
Also, I can ping the workstation now as well.
0
stevenlewisCommented:
Glad to help!
0
x13Author Commented:
After a bit more research, I discovered the following.

Net Send requires to use Windows Messenger service over port UDP 138. Windows XP SP2 firewall blocks port UDP 138 UNLESS you have "File and Printer Sharing" checked off in the Windows Firewall exception list. This explains why the computers with file shares could use windows messenger.

If you don't want File and Printer sharing to be enabled (like me) just add port UDP 138 to the exception list.
0
x13Author Commented:
Oops disregard above, the port to enable is TCP 139 and not UDP 138.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.