[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 685
  • Last Modified:

Crystal Reports Enterprise 8.5 not parsing CSP pages

It was working like a charm, but I broke it by reinstalling the software.  It doesn't serve CSP pages anymore, it just shows the code without parsing it.  Are there any steps that you need to take in IIS?  Perhaps adding an ISAPI filter?

Also, it used to offer some reports in the browser, now it just offers them for download, which appears to not work either.

CWS is running, but iis doesn't seem to be routing requests for .csp/.rpt pages to it.

Thanks,
Bill.
 
Crystal Reports Enterprise 8
Crystal Reports 8.5
Windows Server 2003
IIS 6.0
0
squonk23
Asked:
squonk23
  • 2
1 Solution
 
mlmccCommented:
0
 
squonk23Author Commented:
I have now and no luck.
0
 
squonk23Author Commented:
I don't know why, but the install wasn't adding the ISAPI extensions.  I added the following in IIS --> Default Website Properties -->  Home Directory --> Configuration

.rpt      "C:\Program Files\Seagate Software\WCS\wcsinsapi.dll"
.csp     "C:\Program Files\Seagate Software\WCS\wcsinsapi.dll"
.cri      "C:\Program Files\Seagate Software\WCS\wcsinsapi.dll"
.shtx    "C:\Program Files\Seagate Software\WCS\wcsinsapi.dll"
.cwr     "C:\Program Files\Seagate Software\WCS\wcsinsapi.dll"

Things work better now.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now