?
Solved

local area connection will not send or receive

Posted on 2004-11-29
15
Medium Priority
?
634 Views
Last Modified: 2013-11-15
I just reformated my friends laptop.  It's a CTX EXBook 700e series.  She was running winme before and I put winxp pro on it.  The whole install went fine and everything works fine exept for it not being able to connect to the internet or my network in my house.  

When I look at the local area connection, send and receive are both at 0 and never move.  The ip address seems to be locked on the 196.x.x.x.  If I put a static ip in it still does not work, but it does show the ip and everything else when i look in the local area connection.  The ip, gateway, subnet mask, and dns are right because i've set other computer up on the network using the same ones.  

Does anyone have any idea on how i can get it to start sending and receiving?

0
Comment
Question by:Billc13
  • 7
  • 3
  • 2
  • +2
15 Comments
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12701406
>>The ip address seems to be locked on the 196.x.x.x.
I assume that is not the correct network?
try rebuilding the tcp stack
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q299357
How to Reset Internet Protocol (TCP/IP) in Windows XP

View products that this article applies to.

This article was previously published under Q299357

For a Microsoft Windows Server 2003 version of this article, see 317518.

SUMMARY

When viewing the list of components for a network interface, you may notice that the Uninstall button is disabled when Internet Protocol (TCP/IP) is selected. In Windows XP, the TCP/IP stack is considered a core component of the operating system; therefore, it is not possible to uninstall TCP/IP in Windows XP.

In extreme cases, reinstalling the Internet Protocol stack may be the most appropriate solution. With the NetShell utility, you can now reset the TCP/IP stack back to a pristine state, to the same state as when the operating system was installed.

MORE INFORMATION

The NetShell utility (netsh) is a command-line scripting interface for the configuring and monitoring of Windows XP networking. This tool provides an interactive network shell interface to the user.

In Windows XP, a reset command is available in the IP context of the NetShell utility. When this command is executed, it rewrites pertinent registry keys that are used by the Internet Protocol (TCP/IP) stack to achieve the same result as the removal and the reinstallation of the protocol.

SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

SYSTEM\CurrentControlSet\Services\DHCP\Parameters\

               

Command Usage

netsh int ip reset [log_file_name]

To successfully execute the command, you must specify a log file name where actions taken by netsh will be recorded. For example, typing either of the examples that are listed in the "Command Samples" section later in this article at a command prompt would reset the TCP/IP stack on a system and record the actions that were taken in the log file, Resetlog.txt. The first sample creates the log file in the current directory, while the second sample demonstrates the use of a path where the log will be created. In either case, where the specified log file already exists, the new log will be appended to the end of the existing file.

Command Samples

netsh int ip reset resetlog.txt

netsh int ip reset c:\resetlog.txt

Sample Log File for NETSH INT IP RESET

The following is a sample of the log file that is generated by netsh when an IP reset command is issued. The actual log file may vary depending on the configuration of the system on which the command is issued. In some cases, there may be no actions logged in the file, which typically is the case when the TCP/IP registry keys have not been altered from their original configuration.

reset   SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\15\RegLocation

            old REG_MULTI_SZ =

                SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpDomain

                SYSTEM\CurrentControlSet\Services\TcpIp\Parameters\DhcpDomain



added   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\NetbiosOptions

added   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{BAA9D128-54BB-43F6-8922-313D537BE03E}\NetbiosOptions

reset   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\NameServerList

            old REG_MULTI_SZ =

                10.1.1.2



deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\AddressType

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\DefaultGatewayMetric

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\DisableDynamicUpdate

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\DontAddDefaultGateway

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\EnableDhcp

            old REG_DWORD = 0



added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\NameServer

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\RawIpAllowedProtocols

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\TcpAllowedPorts

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{2DDD011E-B1B6-4886-87AC-B4E72693D10C}\UdpAllowedPorts

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\DisableDynamicUpdate

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\EnableDhcp

            old REG_DWORD = 0



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\IpAddress

            old REG_MULTI_SZ =

                12.12.12.12



deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\IpAutoconfigurationAddress

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\IpAutoconfigurationMask

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\IpAutoconfigurationSeed

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\RawIpAllowedProtocols

            old REG_MULTI_SZ =

                0



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\SubnetMask

            old REG_MULTI_SZ =

                255.255.255.0



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\TcpAllowedPorts

            old REG_MULTI_SZ =

                0



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{5B3675C3-6EB9-4936-B991-04DA31024C4E}\UdpAllowedPorts

            old REG_MULTI_SZ =

                0



added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\AddressType

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\DefaultGatewayMetric

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\DisableDynamicUpdate

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\DontAddDefaultGateway

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\EnableDhcp

            old REG_DWORD = 0



added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\NameServer

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\RawIpAllowedProtocols

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\TcpAllowedPorts

added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BAA9D128-54BB-43F6-8922-313D537BE03E}\UdpAllowedPorts

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\DefaultGateway

            old REG_MULTI_SZ =

                10.1.1.2

               



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\DefaultGatewayMetric

            old REG_MULTI_SZ =

                0

               



added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\DisableDynamicUpdate

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\EnableDhcp

            old REG_DWORD = 0



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\IpAddress

            old REG_MULTI_SZ =

                10.1.1.1

               



deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\IpAutoconfigurationAddress

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\IpAutoconfigurationMask

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\IpAutoconfigurationSeed

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\NameServer

            old REG_SZ = 10.1.1.2,10.1.1.3



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\RawIpAllowedProtocols

            old REG_MULTI_SZ =

                0



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\SubnetMask

            old REG_MULTI_SZ =

                255.255.255.0

               



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\TcpAllowedPorts

            old REG_MULTI_SZ =

                0



reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{BD2859BA-B26A-4E2B-A3FE-3D246F90A81A}\UdpAllowedPorts

            old REG_MULTI_SZ =

                0



deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DontAddDefaultGatewayDefault

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableIcmpRedirect

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableSecurityFilters

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\UseDomainNameDevolution

<completed>

method 2
Had to point the Install to the "nettcpip.inf" in the windows/inf directory. That allows TCP/IP to install over the top of the TCP/IP required for operation of Windows XP.





0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12701415
also try this winsock fix
http://www.spychecker.com/program/winsockxpfix.html
and check for any firewalls, and make sure they are configured correctly (including the built in one on xp and any included with the anti virus program)
0
 
LVL 1

Expert Comment

by:benstorey
ID: 12701726
all that said.. it could be something simple..  

you say the IP is the same as the others.. you have the host address different that the other computer right?
You said 'exept for it not being able to connect to the internet or my network in my house'  ... so you dont even get a connection?

do you have a dhcp server (router/server, etc?) that gives out IP's? or as you said, just setting static for all the computers?
Because if you are setting a static address of 196.x.x.x, that is a public IP address..   do you mean to set it up as 192.168.x.x?

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:Billc13
ID: 12702560
Thanks for the fast replys.  I will try the winsock fix tomorrow.

I have a linksys router that has dhcp enabled on it, but the computer in my network are all assigned static ip's.  192.168.1.100 up to .104.  So the laptop should get the address 192.168.1.105, but it's getting a address like: 192.254.254.1.  Something like that, I can't remember the exact address off hand.  When i put that address in staticly it stays set, but it will not connect to the internet or to the lan.  The only thing i can ping is the loop-back address.  No internet address or any address's on my network will work.

Like I said, tomorrow when i get the laptop back i will run the winsock fix and if that doesn't work i will try resetting the tcp/ip stack.

Thanks again for your time
0
 
LVL 2

Expert Comment

by:avpwest
ID: 12704251
This really sounds like a driver problem.  I believe the laptop has assigned an automatic external IP as it cannot get to the LAN.

Does the automatic address begin with 169.254?  If so, you should try the latest driver for the network card/laptop.  IP addresses in the 169.254 range are being assigned to the machine by XP when it can't communicate with the DHCP server.

Other things to check are the network cable and to try a different network port on the linksys (preferably one you know works)

0
 

Author Comment

by:Billc13
ID: 12707862
Your right, I just doubled checked with my friend on the ip and it does start with 169.254.x.x.  

I've tried every driver I could find for the nic with no luck.  

The nic she has is the linksys pcm100.  It's not the new version.  I also have a PCMPC100 linksys card that is brand new with the driver disk and that doesn't work as well.  My thought was that the problem might have been with the pcmcia drivers.  Winxp most have installed them my it's selft.  In device manager it says Texas Instruments PCI-1131.   Does any one know if these are the right drivers for the CTX EZ-Book 700e series?

The linksys router i have works fine.  All the ports work and it is assigning ip address to dhcp clients perfectly.

I still haven't tried the winsock fix or resetting the tcp/ip stack, but will later.

Any more idea's would be greatly appreciated.

Thanks again
0
 

Author Comment

by:Billc13
ID: 12713002
The winsock fix and resetting the tcp/ip stack did no work.   Still the same problem, send and receive are at 0.
0
 
LVL 1

Expert Comment

by:benstorey
ID: 12713160
If you think the drivers still could be a problem, the up to date drivers for both cards are at these sites..

For yours - http://www.linksys.com/download/driver.asp?dlid=19
For hers - http://www.linksys.com/download/driver.asp?dlid=28

Otherwise.. If you set everything to default, (TCP/ip - all IP's set to obtain automatically..) what do you get when you do an ipconfig in cmd prompt?  is that when you get an ip of 169.x.x.x?   or do you get that as well when you have a static ip set to 192.168.x.x?

sorry just trying to understand exactly when you get the ip of 169..
0
 

Author Comment

by:Billc13
ID: 12713289
Sorry for not being to clear on my problem.

I have the updated drivers from the linksys site and neither of them worked.  I think the drivers for the NIC are ok.

I get the 169.x.x.x address when it's set to obtain automatically.  When I set a static ip, the static ip I set (192.168.1.105) shows up in cmd when i do ipconfig.  The default gateway and dns are also right when i do ipconfig.

The network card plugs into the pcmcia slot.  Do you think the drivers for that could be wrong?  I stated the drivers that winxp installed on it's own above.
(at least I believe it's called the pcmcia slot?)
0
 
LVL 2

Accepted Solution

by:
avpwest earned 2000 total points
ID: 12713821
What XP service pack have you installed on the notebook?  Although taking a look on the CTX support site, there are no drivers for Windows XP.  You may have one of those cases where XP won't fully support that machine.  Have you thought of a USB Ethernet adapter?
0
 
LVL 1

Expert Comment

by:benstorey
ID: 12721934
ok, i know this might seem like going back to what was said before..
but what happens to the other computers if you set it to get an address automatically?  
eg, comp 1 is the problem PC, what happens if you set comp 2 (which is working fine) to obtain IP via dhcp?

If it gets an IP no problem, then we can say that DHCP is working fine...  if not, then you know the problem is with DHCP...
0
 

Author Comment

by:Billc13
ID: 12723110
All the other computer can receive a dhcp address fine if set to do so.  I think avpwest might be right about it not being able to support winxp.  I don't think it supports win2000 either because I tried that and had the same problems.

Tomorrow i'm going to get my hands on a usb ethernet card and give that a shot.  If that doesn't work I guess it's back to winme.

Thanks again
0
 
LVL 2

Expert Comment

by:mivbinfotech
ID: 12725886
dear are you able to ping 127.0.0.1 and ur ip address of the PC itself if yes then the NIC is ok

next check the physical link of the PC i mean the wire may be thats the problem though silly
next remove the cable and put it back again

still if no luck

check the power setting on th NIC sometimes its set to Auto Power save in the properties of the NIC u will find them

let me know i will advise u further
0
 

Author Comment

by:Billc13
ID: 12727441
Yes I can ping the loop back address and 192.168.1.105 if i set it staticly.

The cable is good because I checked it on a working box.

The nic is getting power because all the lights are on.

I'm going to try a usb card later today to see if that helps.

I really think avpwest is right about the ctx 700 series not being able to support xp or win2000.

Thanks again guys for all the replys, it's greatly appreciated.
0
 

Author Comment

by:Billc13
ID: 12733408
Got a USB card and things are running good now.   Thank you all for trying to help.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Windows Server 2003 introduced persistent Volume Shadow Copies and made 2003 a must-do upgrade.  Since then, it's been a must-implement feature for all servers doing any kind of file sharing.
Backups and Disaster RecoveryIn this post, we’ll look at strategies for backups and disaster recovery.
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question