Procomm Plus 4.8 Serial Direct Connect

I have client using Procomm Plus, emulating wyse50, Does not communicate with Server. Have identical pc right next to this one which connects no problem. Checked all settings, both identical. Used same Cable. Connecting thru com 1 direct connect.
OS - XP with SP2. Not sure if problem is with application or OS.
joerock1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnnyCanuckCommented:
First, make sure the serial port is enabled in the BIOS of the machine in question and if possible, set it to 3F8 and irq 4, rather than auto.  Second, SP2 enables the firewall on all connections by default.  See if you can turn it off for the serial connection.
0
NashvilleGuitarPickerCommented:
Also, make sure that COM1 isn't mapped to a network device, such as an old serial printer.  Although this is unlikely, it would prevent communication.  To see if COM1 is being redirected by Windows networking, you can start a command prompt and type "net use" to see a list of redirected ports and drive letters.

If you have followed JuhnnyCanuck's instructions and still can't connect, I find that it is sometimes useful to delete the COM1 port from Device Manager (Control Panel --> System --> Hardware --> Device Manager) and then force Windows to scan for hardware changes (or reboot).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joerock1Author Commented:
JohnnyCanuck - I have tried both your suggestions, but it still didn't work. Thank You for your input.

NashvilleGuitarPicker - Tried your suggestions also. After deleting com1, re-detecting, and reboot I was able to connect.  Maybe Corrupt Registry Settings?
Thank You Also for your input.

0
NashvilleGuitarPickerCommented:
You're welcome.  Windows is sometimes flaky on COM port handling.  It may have been using the wrong driver, or had one of the resource settings slightly off.  It also could have been that JohnnyCanuck's suggestion fixed half of the problem. and that you needed to redetect the port after changing the address.

By the way, this trick works for many other devices as well.  It usually comes down to corrupt or incomplete registry settings, or an old version of a driver.  I have also run in to this problem when upgrading a driver.  The old version had some registry settings which choked the new version.  Deleting and redetecting flushes out the old settings before adding the new ones.

- Will

- Will
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.