Procomm Plus 4.8 Serial Direct Connect

Posted on 2004-11-29
Last Modified: 2008-02-01
I have client using Procomm Plus, emulating wyse50, Does not communicate with Server. Have identical pc right next to this one which connects no problem. Checked all settings, both identical. Used same Cable. Connecting thru com 1 direct connect.
OS - XP with SP2. Not sure if problem is with application or OS.
Question by:joerock1
    LVL 14

    Expert Comment

    First, make sure the serial port is enabled in the BIOS of the machine in question and if possible, set it to 3F8 and irq 4, rather than auto.  Second, SP2 enables the firewall on all connections by default.  See if you can turn it off for the serial connection.
    LVL 5

    Accepted Solution

    Also, make sure that COM1 isn't mapped to a network device, such as an old serial printer.  Although this is unlikely, it would prevent communication.  To see if COM1 is being redirected by Windows networking, you can start a command prompt and type "net use" to see a list of redirected ports and drive letters.

    If you have followed JuhnnyCanuck's instructions and still can't connect, I find that it is sometimes useful to delete the COM1 port from Device Manager (Control Panel --> System --> Hardware --> Device Manager) and then force Windows to scan for hardware changes (or reboot).

    Author Comment

    JohnnyCanuck - I have tried both your suggestions, but it still didn't work. Thank You for your input.

    NashvilleGuitarPicker - Tried your suggestions also. After deleting com1, re-detecting, and reboot I was able to connect.  Maybe Corrupt Registry Settings?
    Thank You Also for your input.

    LVL 5

    Expert Comment

    You're welcome.  Windows is sometimes flaky on COM port handling.  It may have been using the wrong driver, or had one of the resource settings slightly off.  It also could have been that JohnnyCanuck's suggestion fixed half of the problem. and that you needed to redetect the port after changing the address.

    By the way, this trick works for many other devices as well.  It usually comes down to corrupt or incomplete registry settings, or an old version of a driver.  I have also run in to this problem when upgrading a driver.  The old version had some registry settings which choked the new version.  Deleting and redetecting flushes out the old settings before adding the new ones.

    - Will

    - Will

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension ( This reminded me of questions tha…
    I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
    Using Adobe Premiere Pro, the viewer will learn how to set up a sequence with proper settings, importing pictures, rendering, and exporting the finished product.
    Introduction to GIMP:  GNU Image Manipulation Program. It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now