~/Sites and CGI

Hi,

I'm having trouble getting the web server to run my perl CGI scripts on my Powerbook, which is running OS X 10.3.6.

I followed this guide :

http://docs.info.apple.com/article.html?artnum=42734

When I try to access the CGI, I get a 403 message :

You don't have permission to access /~test/bluewave/tmp2.cgi on this server.

This is the httpd.conf section :

<Directory />
    Options FollowSymLinks
    AllowOverride Options
</Directory>

% cat ~/Sites/.htaccess
Options +ExecCGI

% ls -l ~/Sites/bluewave/tmp2.cgi
-rwxr-xr-x 1 test test 129 30 Nov 12:09 /Users/test/Sites/bluewave/tmp2.cgi

I can access regular html in the bluewave directory, but the CGI won't run.

Any ideas?

Max.
davidmaxwatermanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

periwinkleCommented:
You really should put the +ExecCGI in the httpd.conf section...

In your virtual host in the httpd.conf , you should have something like:

<Directory /Users/test/Sites>
Options FollowSymLinks
order allow,deny
allow from all
<Limit GET POST>
order allow,deny
allow from all
</Limit>
</Directory>
ScriptAlias /cgi-bin/ /Users/test/Sites/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ahoffmannCommented:
Options FollowSymLinks +ExecCGI
0
periwinkleCommented:
ahoffman - yep - thanks for the catch!
0
davidmaxwatermanAuthor Commented:
Just to followup...

Since this is an Apple OS X specific configuration, I think the fully correct answer is what I was told on Apple's support web site :

http://discussions.info.apple.com/webx?14@216.YbZJaKEiCEC.2@.68a02433/2

But I am sure that what you put would also have worked :)

Thanks for your help!

Max.
0
periwinkleCommented:
David -

Glad to hear that your problem is solved - and thanks for the points!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.