Installing USb Flash Card

I am a absolute linux newbie, i have been loading my first linux server(debian), my longterm goal is to start replcaing my win servers with linux. I have a machine loaded that does not have internet access yet and i need to setup nvidia drivers, which i downloaded off the net on to a win 2000 server. I wanted to use my usb memory stick to copy the drivers onto the linux machine.
I have read quite a theads on this topic, but all the files/directories that they request are not present on my machine.

I have no SDA drives, it doesnt look like SCSI is set up on my machine, in one of the threads they mention that the flash drive uses SCSI emulation. I cannot find a hotplug service on this machine,.

I have read the following thread

Solution Title: how to install usb flash drive on linux laptop?
asked by ilyaz on 07/31/2003 07:53PM PDT

All the commands they mention in this thread, i cannot find

I another thread, they mention that you must go to the following web site to get the hotplug service, but his page doesnt work
 install the hotplug package
 ( hotplug  is  developed  by  Linux Hotplugging Project linux-hot-plug.sourceforge.net/">http://linux-hot-plug.sourceforge.net/ )


Can someone tell me how to go about installing this memory stick from scratch

Thanks

mustekkznAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gtkfreakCommented:
0
mustekkznAuthor Commented:
Thanks

I am busy reading through the document, it looks quite interesting.
0
gtkfreakCommented:
I connected a Casio Exilim Camera to USB port as follows:
# su
# mkdir /mnt/camera
# ls -la /mnt/sda1
Connect your USB flash device, and then give the following command. On switching on the camera, it got detected and following command allowed me to read its contents.

# mount /mnt/camera
0
gbonneCommented:
Never mind the "SDA" drives or the scisi support. A standard full install of any distro should have them already setup.

When you plugin a USB key it will be recognized by the linux kernel as a scsi device already.

The only thing you need to know is how the USB device has been "formatted". This is the real problem as there is no "easy" way to find out. Usually, if you originally format it with a Windows 2k or XP, then it will be partitionned like a hard disk. But if you never formatted it then you have to try and see which works.

In any event you will need a mount point:
mkdir /mnt/usbstick

Next you plug it in. If you have no other scsi storage device (do not forget that an external CD/DVD writer could be scsi) then the stick will 99% of the time be assigned the scsi storage device a (or /dev/sda).

Then here comes the trial and error phase (is the stick partitionned like a hard disk or formatted like a big floppy/zip disk?):

Try this first (most likely to work):
mount -t vfat /dev/sda1 /mnt/usbstick

If it says nothing it worked... You should see your files in the directory /mnt/usbstick, your stick is partitionned like a hard disk.

If it failed then try:
mount -t vfat /dev/sda /mnt/usbstick

Note the "1" after /dev/sda is gone. If it worked then you're OK and the usb stick is formatted as a Zip drive or "big floppy".

If it still fails then either the stick is not on /dev/sda but maybe /dev/sdb.. Try again the same with /dev/sdb... If that fails then either you have more than two scsi storage devices already plugged in (if you are sure about that then check /dev/sdc, etc...) or the USB stick was not properly recognized or it was formatted in a strange way (note that some USB sticks can be formatted with a security/password protection so that you need special drivers to access the files, this is not supported in linux as far as I know).

If you are sure that you have no other scsi storage devices on your linuxbox then try plugging out and back in the usb stick then issue the following command and post the result here:
tail -30 /var/log/messages

That will allow us to see where your linux box has put your USB stick or if it did not recognize it at all.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mustekkznAuthor Commented:
thanks guys for your info, unfortunately another crisis has occured that needs my attention right now, it will be a week or so before i can get back to linux.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.