Can map drive, Can't browse via workgroup

Hello,

Have a small, nagging problem on my home wireless network.

All network kit is Netgear.
All OS are XP Pro
There are 3 PCs in the network
All are in the same workgroup

The problem:
One of the PCs cannot be browsed to from My Network Places

PC1 can browse PC1
PC1 can't browse PC2
PC1 can browse PC3

PC2 can browse PC1
PC2 can browse PC2
PC2 can browse PC3

PC3 can browse PC1
PC3 can't browse PC2
PC3 can browse PC3

The strange thing is, is that from PC1 and PC3 I can map a network drive to shares on PC2 without having to enter a username and password. The problem comes when I come to browse the workgroup for PC2. I can see PC2 but trying to get in there results in Windows returning a message that reads "Access is denied".

I can ping all three boxes from all three boxes

I am only using simple file sharing at the moment.

The built in Firewall is not enabled on any connection

I have added lots of accounts, including Everyone to the local security policy for users that are able to access the computer via a network

So, the main problem is, is that whilst I can map a network drive to PC2, I have to know the name of the share as I cannot browse to it.

Any ideas please?

Many thanks

Richard


LVL 3
richardSladeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
On PC2, be sure that NetBios over TCP/IP is enabled, not set "default"
---------------

Enable NetBios over TCP/IP in WIndows XP

   Click Start, click Control Panel
   Click Network Connections.
   Right-click "Local Area Connection", and then click "Properties".
   Click on (highlight) "Internet Protocol (TCP/IP)", and then click "Properties" button
   Click the General tab, and then click "Advanced" button , bottom right.
   Click the WINS tab.
   Under "NetBIOS setting" section, click Enable NetBIOS over TCP/IP, and then click OK two times, the "close".
     ( ) Default
     (*) Enable NetBios
     ( ) Disable NetBios

   Reboot the computer.

Do you have anything on PC2 such as a Cisco VPN client or other product that has a built-in firewall?

Try enableing the Guest account on PC2 just for testing. If you can now browse to it, then we've narrowed down the issue at least..
0
lrmooreCommented:
Are all 3 PC's wireless, or just PC2?
0
richardSladeAuthor Commented:
All 3 are wireless.
All 3 have netBios over TCPIP on and Computer Browsing is on in services

Cheers

Rich
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

lrmooreCommented:
OK, more ideas:

Do you have anything on PC2 such as a Cisco VPN client or other product that has a built-in firewall?


Windows XP (at least PRO) defaults a setting in Local Security Settings to something very unhelpful.
If all this does not solve your problem, check Local Security Settings, Network access: Sharing and security model for local accounts.  This may be set to (default) Guest only - local users authenticate as Guest.  Change this to Classic: local users authenticate as themselves.

Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"

FOR HOME USERS ONLY WHEN ALL ELSE FAILS:
Look for and set these properties as shown also

Network access: Allow anonymous SID/Name translation     ==> Enabled
Network access: Do not allow anonymous enumeration of SAM accounts     ==> Disabled
Network access: Do not allow anonymous enumeration of SAM accounts and shares          ==> Disabled
Network access: Let Everyone permissions apply to anonymous users     ==>      Enabled
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
richardSladeAuthor Commented:
Thanks. I'm at work at the moment, so I can't try it. I know that I have been fiddling with the local policies but I don't think I have tried what you have suggested. Will try tonight and let you know.

Many thanks

Rich
0
richardSladeAuthor Commented:
oh - and no, there are none of the programs / firewalls that you suggested on this box :o(

Cheers

R
0
richardSladeAuthor Commented:
Hi,

I have given this a go...
Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"

But it didn't fix anything.

Additional info that may help. My connection on PC2 is bridged. Without bridging the connection I cannot even see teh workgroup from PC2.

Thanks for your help

R
0
richardSladeAuthor Commented:
Right... an amendment to the previous post.

I CAN now see PC2 from PC1 but not from PC3. PC1 and PC2 have the same username and password (though not in the same case) and PC3 has a different user account. I thought though as I was using simple file sharing the user account didn't matter. Do I have to have the same account on all machines? I hope not.

Cheers

Rich
0
lrmooreCommented:
> Do I have to have the same account on all machines?
Yes, or enable the guest accounts
0
richardSladeAuthor Commented:
Thanks ... I think I can get it sorted from here then :o)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.