Which RPM does libhistory.so.5 reside in

I'm trying to install apt (http://linux01.gwdg.de/apt4rpm/)  for Suse 9.2 and when I run it, I get the following error - any idea how to install this?

alta:/home/mraible/downloads # rpm -i apt-0.5.15cnc6-rb.suse092.6.i586.rpm
warning: apt-0.5.15cnc6-rb.suse092.6.i586.rpm: V3 DSA signature: NOKEY, key ID 8
c9b4b0d
error: Failed dependencies:
        libreadline.so.5 is needed by apt-0.5.15cnc6-rb.suse092.6
alta:/home/mraible/downloads #
LVL 1
mraibleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

grbladesCommented:
Hi mraible,
It comes with readline I believe.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mraibleAuthor Commented:
Hmmm, can't seem to get readline-devel installed:

alta:/home/mraible/downloads # rpm -U readline-4.3-306.i586.rpm
        package readline-4.3-306.5 (which is newer than readline-4.3-306) is already installed

So since it already appears to be installed, I tried readline-devel, but no luck:

alta:/home/mraible/downloads # rpm -i readline-devel-4.3-306.i586.rpm
error: Failed dependencies:
        readline = 4.3-306 is needed by readline-devel-4.3-306
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

grbladesCommented:
I think you need to get the very latest versions of both and then upgrade readline to the latest and then install readline-devel.
It looks as though readline-devel is not installing because the minor version is not correct.
0
wesly_chenCommented:
Hi,

   You has readline-4.3-306.5 so you need readline-devel-4.3-306.5.i586.rpm
which is in SuSE installation CD 3, path /suse/i586/readline-devel-4.3-306.5.i586.rpm
Copy from your SuSE CD and install it.
# rpm -ivh readline-devel-4.3-306.5.i586.rpm

Or you can use YasT to install it.

Wesly
0
mraibleAuthor Commented:
The major problem I'm experiencing is I'm trying to remotely build a box that has literally *nothing* on it - not even gcc.  My task is to install CVS, Java, etc. and I figure using "apt-get" is one of the easiest ways.  I can't compile anything b/c I don't have gcc.  I don't have the CDs and they're not available b/c the guy who set it up is on vacation for a week.  I can't use YaST (no CDs) or YOU (don't know username/password), so that's why I am where I am.

I can't seem to find the readline-devel RPM on the net:

http://www.google.com/search?q=readline-devel-4.3-306.5.i586.rpm

Matt
0
grbladesCommented:
I have just got home from work but if you send me an email (my address is in my profile) I can email you back the files tomorrow morning as I have the DVD for my desktop in my desk.
0
wesly_chenCommented:
Hi,

  If you cannot get readline-devel-4.3-306.5.i586.rpm from SuSE's installation CD,
then downgrade the readline to 4.3-306.
# rpm -e readline-4.3-306.5    <=== remove it
# rpm -ivh readline-4.3-306.i586.rpm readline-devel-4.3-306.i586.rpm

Wesly
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.