Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 295
  • Last Modified:

Windows XP - Home and Pro Networking problems

I have XP computers in my office. 2 are Pro machines and 3 are Home. All of the Home computers connect together no problem. But I can never connect to the Pro machines. On my machine, I can see all workgroup computers which include both Home and Pro but can't connect to the Pro machines. What would cause this?  
0
kornflake
Asked:
kornflake
  • 6
  • 2
  • 2
  • +4
1 Solution
 
luv2smileCommented:
Do you get any kind of error message when you try to connect? That would be helpful in trying to figure out the problem.
0
 
lrmooreCommented:
Try this:
-------------
Turn on "Simple file sharing" on the XP (Pro only) machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
For complete explanation, see here:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;304040
0
 
Rabba367Commented:
I do not have a network per se, but I run VirtualPC which uses a network and whenever Pro is the Host Computer - I have this problem.  What I find works for me is to go into Advanced Settings of my NIC card and uncheck the box that says Enable IEEE 802.1 Authentication for this network (Start>Settings>Network Connections>Local Area Connection>Properties>Authentication).
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
HSolo327Commented:
I common solution that I have seen is installing NetBEUI protocols.  They are not installed by default, but they are on your Windows XP: Pro CD.

From: http://support.microsoft.com/default.aspx?scid=kb;en-us;301041&sd=tech
Insert your Windows XP CD-ROM in the CD-ROM drive and then locate the Valueadd\MSFT\Net\NetBEUI folder.
2.      Copy the Nbf.sys file to the %SYSTEMROOT%\System32\Drivers folder.
3.      Copy the Netnbf.inf file to the %SYSTEMROOT%\Inf hidden folder.

This is very bad though as NetBEUI is an old and vulnerable technology.
--------
Another solution is this:

On all of your machines, add entries into your lmhosts file.

C:\windows\system32\drivers\etc\lmhosts.sam

Open it with notepad and scroll to the bottom.  It is best practice to have nothing but the entries in the file as the entire file is parsed whenever it is accessed, but I can't quite remember where to put the new file and I don't want to give bad information.

you'll want to make an entry for each machine on your network.  You can do this using the IP addresses (if you are connected via a router) or using the NetBIOS names (if you are connected via a switch).  An entry will look like this:

#PRE #DOM:xxx.xxx.xxx.xxx #INCLUDE <C:>

this would automatically create a connection to the remote computer and allow access to the C: drive.

Use the search computers option (Start->Search->Computers) to pull up the computer or alternatively, use \\computername or \\IP to connect to the computer.  You can then map that remote drive to a local drive on your computer if you wish.
0
 
eatmeimadanishCommented:
You need to enable the guest account on the Windows XP Pro boxes in order for home to login. Don't bother with the above. This will post likely pouch your config.  
0
 
Rabba367Commented:
I read your qeustion very carefully again - you state you can see the network - but cannot access the network.  By default Windows XP-Pro sets itself up for a secure network - hence the IEEE 802.1 aurhenication scheme.   If you refer to  the address below, you will find more information on IEEE 802.1.  As I said I use VirtualPC to teach myself networking and each so-called virtual box has a virtual NIC card.  If you try my suggestion first, you will not have to undo anything if it does not work - except re-tick the box for each XP-Pro machine.   If you wish to follow all of the steps to enable it across the board - the instructions are at this address.  However, if you are behind a firewall, and you only have one machine that can reach the net - others going through that machine - then the IEEE 802.1 is really redundant, but it would be your call.  The address is:

http://www.jsiinc.com/SUBL/tip5900/rh5964.htm
0
 
kornflakeAuthor Commented:
When I try to access the Pro computer through the workgroup view -the following error message appears -

XXXXX is not accessible. You might not have permission to use this network resource. Contact administrator blah blah blah...The network path was not found.

This still happens AFTER I enable a guest account on the Pro machine.
0
 
luv2smileCommented:
A few things I suggest:

Make sure you turn OFF simple file sharing

Make sure you have disabled the XP firewall if they are SP2

Check your NTFS permissions on your local drive.  Right click drive, click properties, then the security tab. This lists who has access to the
drive...make sure these are correct.

Also make sure you have the same username and the same password for that account added to all computers in the workgroup.
0
 
kornflakeAuthor Commented:
My local drive or the local drives on Pro?
0
 
kornflakeAuthor Commented:
I can't see the NTFS option you mean - all I see is a Sharing tab
0
 
pcavenueCommented:
smile you got it, too bad it was just worth 125 points, i think you deserve more than that.

-dp
0
 
kornflakeAuthor Commented:
Ok, disregarding pcavenue, can anyone give me info that actually useful?
0
 
HSolo327Commented:
Okay, I misunderstood your problem when I first answered.  This sounds a bit easier.

On your XP: Pro machines, go into Control Panel=>Administrative Tools=>Computer Management=>Local Users and Groups=>Users

Add a new user for each XP: Home machine that you have.  The easiest thing to do, if you want the XP: Home machines to have full access, is to make the new users members of the Administrators group.  Be sure that the new user names and passwords are identical to the login information on each XP: Home machine.  Go to the drives on your XP: Pro machines.  Open properties and click the Security tab.  Administrators should already be allowed to access the drive fully, but you may want to explicitly add each of the new users you created.  This may fix your problem.

You may also want to open your Local Security Policies (In Administrative Tools) and open User Rights Assignment.  Check the following policy:
Access This Computer From Network           (Be sure Administrators is in the list)

0
 
kornflakeAuthor Commented:
Hm...tried all of that - also tried pinging the Pro machines - and got request timed out for both. What does this mean?
0
 
kornflakeAuthor Commented:
Ok, HSolo, I'm about to accept your answer - I got most of the computers connected the way you said. There is still one more computer thats having trouble. When I run the Network Wizard, I specify the workgroup name very specifically and then I try to list all computers in that workgroup but it says that its not accessible. What can this mean? All of the other computers are now fine except this one....
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 6
  • 2
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now