SCSI RAID 0 , 3 disk , Raid Doesnt find one member

I have a three disk SCSI RAID 0 configuration.
Just out of the blue when rebooting the array doesnt find one member and doesnt boot.
If i run the adaptec disk utilities and scan the scsi bus i can see all three disks

Any ideas? Is one disk dead? If so, any way i can retrieve my data?

HELP!!
cparthAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tfjeffCommented:
well, generally when a disk goes offline in a raid 0 your data is considered lost...that's the danger of raid 0....adaptec controllers will generally give you the option to run a "verify" or "media verify" or "verify disk media" in the "disk utilities" section, run the verify on the disk that is being reported as offline, this will tell you if the disk is dead....what adaptec controller do you have?  What type of server do you have?  Hopefully you had a backup because the adaptec controllers I've worked with weren't too friendly in situations like this.
good luck,
jeff
0
Duncan MeyersCommented:
As tfjeff says: if you have a drive failure in a RAID 0 array, kiss your data goodbye.

You *may* (again, as tfjeff says) be able to recover data. Try CTRL-R when you are in the BIOS RAID configuration utility. But, sorry to say, I'd suggest you find your backups and prepare for a rebuild. Best to use RAID 5 in future so that your data is protected by RAID 5's parity schema.

0
cparthAuthor Commented:
The weird thing is ..i can verify all three disks without problems.
And it does not tell me what disk is missing.

I have an adaptec 2120s

if i try to recreate the array it says : no space, delete array first

could it be the controller? If so can i install a new one without losing my data?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

tfjeffCommented:
if you go into "manage containers" one of the disks should be greyed out or missing, this should let you know which one it is, as meyersd says control+r is about your only hope, but since you have raid 0 and a control+R will force all the drives online into a raid 5 it probably won't work.
0
Cyber-DudeCommented:
Just in-case you may need it;

Here is a RAID 0 reconstructor software might be helpful...
http://www.runtime.org/raid.htm

Good luck

Cyber

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gyazigiCommented:
Usually RAID 0 problems are painful, you may try the following:
1- get the latest update for the firmware from ADAPTEC.COM you should update  2120s to the latest firmware level. [boot with the update generated floppy if possible]
2- try to unplug your HDD then replug it [or disconnect data/power cables then reconnect if this works it means you had a bad contact, try to replace the data cables if need be.
3- press CTRL_R or CTRL_M try to verify the RAID volumes you may need to rebuild but don't do it at this stage.
4-If everything fails, check doctorbyte.us, ontrack.com ...
5- if you have a backup rebuild the system but you have to get a 4 HDD so you may form a RAID 10 which has faster writes and better recovery.

Good Luck,
Geo..
0
cparthAuthor Commented:
if i do CTRL M  i get no array present
if i do CTRL R  he updates drive info and finds all three
if i verify them they all check out
if i do create array i get: there is no free space, delete array

what if i do initialize? i lose all data?

any ideas..i'm desperate..
0
cparthAuthor Commented:
GUY'S I solved it..
i used another ata disk , setting up xp , then booting from there.

i recreated the raid 0 array initializing the disks, but let them alone.

Then i used getdataback for ntfs..to recover the data..

i got everything back i needed!!

yippiee yee yeee..going raid 5 now..

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.