?
Solved

ORACLE instance terminated. Disconnection forced

Posted on 2004-11-30
7
Medium Priority
?
696 Views
Last Modified: 2013-12-11
Hi ,
I am running Oracle 9i on RH Linux. I created a database. Everything went smooth till when I am trying to start  the database  I get  ORACLE instance terminated. Disconnection forced it works just fine with STARTUP NOMOUNT . Further looking into alert_${ORACLE_SID}.log I see
"ORA-1092 signalled during: ALTER DATABASE OPEN.." . After going through error manual I understand  The environment variables ORA_sid_PWFILE and ORA_PWFILE are not set.
Before I define these enviornment variable what should be the exact path to these orapw file . I have one $ORACLE_HOME/dbs/orapw${ORACLE_SID} and other in $ORACLE_BASE/oradata/$ORACLE_SID/orapw. Are these the correct path ?
Another question related to the same issue is initiallay in my init${ORACLE_SID}.ora. I had
REMOTE_LOGIN_PASSWORDFILE=EXCLUSIVE set, later to overcome this issue I set
REMOTE_LOGIN_PASSWORDFILE=NONE but still having the same problem why? Do I need to change control file or some thing ?
Thanks
Sanjoy
 
0
Comment
Question by:sanjoybasu
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 8

Expert Comment

by:Pierrick LOUBIER
ID: 12714072
Try to set :

ORA_PWFILE=$ORACLE_HOME/dbs/orapw${ORACLE_SID}
ORA_sid_PWFILE=$ORACLE_BASE/oradata/$ORACLE_SID/orapw

If you set parameter REMOTE_LOGIN_PASSWORDFILE to NONE, you have to use secure connections (like ssh, not telnet). You may need to recreate the password file and set REMOTE_LOGIN_PASSWORDFILE back to EXCLUSIVE.

Here is part of official documentation :

Setting REMOTE_LOGIN_ PASSWORDFILE
In addition to creating the password file, you must also set the initialization parameter REMOTE_LOGIN_PASSWORDFILE to the appropriate value. The values recognized are:

NONE: Setting this parameter to NONE causes Oracle Database to behave as if the password file does not exist. That is, no privileged connections are allowed over nonsecure connections. NONE is the default value for this parameter.

EXCLUSIVE: An EXCLUSIVE password file can be used with only one database. Only an EXCLUSIVE file can contain the names of users other than SYS. Using an EXCLUSIVE password file lets you grant SYSDBA and SYSOPER system privileges to individual users and have them connect as themselves.

SHARED: A SHARED password file can be used by multiple databases running on the same server. However, the only user recognized by a SHARED password file is SYS. You cannot add users to a SHARED password file. All users needing SYSDBA or SYSOPER system privileges must connect using the same name, SYS, and password. This option is useful if you have a single DBA administering multiple databases.


Suggestion:

To achieve the greatest level of security, you should set the REMOTE_LOGIN_PASSWORDFILE initialization parameter to EXCLUSIVE immediately after creating the password file.
0
 
LVL 48

Expert Comment

by:schwertner
ID: 12714098
You have to ensure correct values in
ORACLE_HOME
ORACLE_BASE
environment variables.
Check these variables.
It seems they are changed and so the spfile could not be found.
To open the database find in $ORACLE_BASE/admin/.../pfile directory and copy the parameter file
to a file like init.ora.
Try to open so:
SQL>startup pfile=......./init.ora
0
 
LVL 48

Accepted Solution

by:
schwertner earned 2000 total points
ID: 12714119
And if this is 9.2.0.1 more likely this is an Oracle bug, fixed in the next releases.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
LVL 10

Expert Comment

by:peterside7
ID: 12716915
You're NOT using the init.ora file, you're using the spfile.

set REMOTE_LOGIN_PASSWORDFILE=NONE in the spfile

or rename in $ORACLE_HOME/dbs the spfile to use the init.ora file.

It will work.
0
 
LVL 10

Expert Comment

by:peterside7
ID: 12716940
ALTER SYSTEM SET REMOTE_LOGIN_PASSWORDFILE=NONE SCOPE=SPFILE

to modify the spfile directly
0
 

Author Comment

by:sanjoybasu
ID: 12720050
Thanks for your overwhelming response. I am working and will get back with status
0
 

Author Comment

by:sanjoybasu
ID: 12780080
Thanks all for your time however I would like to specially thanks schwertner for final solution. I was using 9.2.0.1 and after exhausting all method I decided to go for 9.2.0.4. dbca still remains a major heart burn. Manually creating database works fine..
Thank you once again schwertner.
0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I remember the day when someone asked me to create a user for an application developement. The user should be able to create views and materialized views and, so, I used the following syntax: (CODE) This way, I guessed, I would ensure that useā€¦
This article will show a step by step guide on how to mask column values in Oracle 12c using DBMS_REDACT full redaction option. This option is available on licensed Oracle Enterprise edition as part of Oracle's Advanced Security.
This video shows how to Export data from an Oracle database using the Datapump Export Utility.  The corresponding Datapump Import utility is also discussed and demonstrated.
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function

599 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question