Can't find domain after reboot when connecting or disconnecting from port replicator

The COO of my company has a IBM T40 Type 2379 laptop with Windows XP Professional SP2.  Here at work he places the laptop on a port replicator when at his desk and uses it standalone while away from it (i.e. conference room here, at home, travelling, etc...)  While connected port replicator he uses a wired connection to connect to our network (static TCP/IP) and when disconnected from the port replicator he uses our wireless connection (Netgear WGR 614 with DHCP enabled).  If he disconnects from the port replicator and reboots (whether he redocks it or not) he is unable to reconnect to the domain and thus can not log in.  I have found that if I log in locally on the computer, as an administrator, I can remove the domain, reboot, and then reattach the domain.  After doing this he is able to connect to the network regardless of whether he reboots or not connected or disconnected from the port replicator.  Unfortunately when he brings it back into the office the next day the same problem occurs.  At home he connects using his 2wire wireless router (logging in with the same profile and domain just with no real domain connection).  Any ideas?  Need more information or clarification?
LVL 3
srejjaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nolimitscrdCommented:
Make sure all the connection have the firewall disabled and the smart card options have been unchecked.
0
Jasonw3Commented:
I have run into a similar situation at my workplace.  What we discovered was that the IP address was not getting released and the system continued to try and contact the network resources using the old IP.  It was possibly due to the lease time on the DHCP given address not having expired.  It also wouldn't work if you simply renewed the IP, you had to RELEASE it first.

Try running ipconfig /release on both adapters, shut down and attempt to recreate the problem.

If it does work, you could run a logoff script to automatically release it for him on shutdown, or a batch file on the desktop that enables a one-click release if he frequently docks/undocks between shutdowns.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MasterOpCommented:
Your problems comes from the wireless router/switch that you are using. By default he is acting as a gateway. While you are in a gateway mode you can't access the domian using the wireless unless you haven't get your network setting before that by connecting it to the LAN cable. There is very easy way to fix this :) Most wireless router/switch-es have settings that can be accessed by "http://" find that settings in the manual. Then look for the part of the menu called "routing". There you will see what role is your wireless router/switch assuming now. if it is Router or Gateway you won't be able to access the domain unless you setup the reference to the network with some IP routiing, but you still might not be able to connect to the domain, if your wireless router/switch does not support Transperant DNS. WIthout it you won't be bale to access the comps by NetBIOS name, but only by IP. That's also why you don't have connection to the domian once you resteart in wireless mode. The solution is often very simple. Remember that part i was  talking about in the routing menu... well there is another option rather than Router or gateway. It is called "RIP 2". Using that one your wireless router/switch acts just like an ordinary LAN switch. That's it !

Have fun!
0
BjornEricssonCommented:
in command promt, ipconfig /renew is another quick way to do this.
/B
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.