"Library not registered" error when executing command "Set fs = createobject("Scripting.FileSystemObject")"... please help

I have a .VBS script file that executes the command:

Set fs = createobject("Scripting.FileSystemObject")

A guy at work just got a new laptop computer and when the script runs, it errors out on the command.  The error it gives is:

Library not registered

The only difference between his computer and all of the others at my work is that his has Windows XP SP2.  Everyone else has XP SP1 or 2000 (or NT4).

What is wrong?  I tried installing Windows Script v5.6 for XP but that didn't solve the problem

Thanks
dougshepardAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SRigneyCommented:
Scripting.FileSystemObject is scrrun.dll in WINNT\System32

Make sure he has it and it is registered.

0
muzzy2003Commented:
Does he have Symantec anti-virus? Have heard that can block calls to scrrun objects.
0
dougshepardAuthor Commented:
I will try this once I have access to his computer again, but when I unregister that DLL file on my computer (which worked fine before) I get the following error:

Activex component can't create object: 'Scripting.FileSystemObject'

Not the error I gave above that the other computer is getting...

So I'm wondering if the DLL isn't already registered and the problem lies somewhere else...

I'll post again after I try it... any other ideas would be greatly appreciated in the mean time.

Thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

muzzy2003Commented:
Try unregistering C:\WINNT\SYSTEM32\vbscript.dll on your computer - does that give you the right error message?
0
dougshepardAuthor Commented:
Nope, then I get this error:

Can't find script engine "VBScript" for script "whatever.vbs".

Thanks
0
muzzy2003Commented:
Nope, OK. Found one link that suggested registering this file might be the key, but obvioulsy not.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dougshepardAuthor Commented:
Thanks...

damn Crystal Reports !
0
JohnBPriceCommented:
Glad to help, I had a similar problem where Crystal messed up registry security & I couldn't upgrade Norton AntiVirus.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic Classic

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.