Cisco 2950 lost IOS after simple power down HELP!!!!

Hello,
   Today while working on a server in a client rack i restarted the power which reset the cisco 2950, then it just sits then blinking the stats light green and all ports are yellow. When i console in i get "switch:" I have no idea what its doing, I can't type in dir flash says permison denied so i don't know what to type in for the boot name or how to get it running again. I have to get this swtich back to the client by 7am eastern i am out of ideas HELP! Thank you for your time.
   Brock
AccusonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mikebernhardtCommented:
Not sure why that happened, unless a specific version of software was specified in the config, which isn't in the flash. I would get on the console and
1. type flash_init
2. type dir flash: so you can then see what's in there, if anything.
3. If there's a good binary there, type "boot flash:[the binary name]"

Once it boots, type "show boot" to see if the switch is looking for something that isn't there. If it is, change it by typing, in config mode "boot system flash:[the good binary name]"

If there's nothing on flash and it won't boot, you'll need to tftp a new image on there. But you always have to type "flash_init" from the switch: prompt to use the flash.

Try rebooting the switch while you're on the console and watch the boot sequence, that will also give you good information about the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AccusonAuthor Commented:
Directory of flash:/

2    -rwx  1535      <date>               config.text
3    -rwx  5         <date>               private-config.text

7738368 bytes available (3072 bytes used)
switch:

Thats what i got so far i am trying to get one to load now no luck so far, i am very rusty in this area of cisco.... Thanks a million for the fast answer
0
AccusonAuthor Commented:
C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(11r)EA1, RELEASE SOFTWARE (fc1)                                                                              
Compiled Mon 22-Jul-02 17:18 by antonino                                        
WS-C2950-24 starting...                      
Base ethernet MAC Address: 00:11:5c:78:44:40
Xmodem file system is available.
Initializing Flash...
flashfs[0]: 2 files, 1 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 7741440
flashfs[0]: Bytes used: 3072
flashfs[0]: Bytes available: 7738368
flashfs[0]: flashfs fsck took 4 seconds.
...done initializing flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4
Loading ""...: permission denied

Error loading ""

Interrupt within 5 seconds to abort boot process.
Boot process failed...

The system is unable to boot automatically.  The BOOT
environment variable needs to be set to a bootable
image.

switch:
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

AccusonAuthor Commented:
thats the console when the switch is restarting... this makes no sense the switch is maybe a month old.. brand new and all that happend was a restart. Thanks again for everyones help.
0
mikebernhardtCommented:
You have no binary image in your switch. It's like booting a PC with no operating system. Something is weird, becasue it's looking for an empty image name. If you have access to a boot image, you can use xmodem to load a new one in. It will take forever but it will work. You can also use tftp to do it, but it's more complicated.

Please read the following Cisco lonk for full details:
http://www.cisco.com/en/US/products/hw/switches/ps628/products_tech_note09186a0080169696.shtml
0
AccusonAuthor Commented:
I have no images here, I run a old cisco 2924 in my office and don't have access to another switch until its to late tommarow. I just don't get how this happend what caused it. What should i do from here? The switch is out of a medical facility...
0
mikebernhardtCommented:
Did you buy the switch new and if so, how long ago? Your switch is licensed to have the version of software it came with if you bought it new. It comes with a warranty that may or may not be expired. I would talk to the vendor to get replacement software and failing that, talk to Cisco.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.