Cannot load Xserver/KDE on fresh Mandrake 10.1RC x86_64 install

Howdy,

Hardware setup is as follows:
AMD64 3400+
Gigabyte K8NS Pro mobo
Onboard Audio
nVidia GeForce440mx
WD1200JB
WD2000JB
WD600BB
Pioneer DVR-108
Marvell Yukon Gigabit LAN


I'm again trying to move over to Linux and am totally unable to get a GUI started. I've reinstalled Mandrake twice, using two different burns off of two seperately downloaded ISOs and have tried with Debian also. I'm assuming this has something to do with my video card/64 bit setup. It works fine from command line, but that really isn't much use to someone who's not at all familiar with Linux, IE Me.

My question is what do I have to do, in English not Linux-ese, to get it to work?

I have network access in the command line so I can download something, if someone can tell me what it is that I need to download.
LVL 2
RobbieCrashAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lynxlupodianCommented:
Can you paste the errors here - wrong X settings are one of the more common errors, although mandrake should run out of the box.
0
RobbieCrashAuthor Commented:
I'm not sure if this is what you need but it's what I get at start up after I log in:

execve failed for etc/x11/x (errno 2)
giving up

X init: no such file or directory (errno 2): Unable to connect to X Server
X init: No such process (errno 3): Server error

The giving up part makes me sad.
0
lynxlupodianCommented:
find / -iname xinit #to check where it is located, if it exsists at all - it should
#I have them in
/etc/x11/xinit
/usr/X11R6/bin/xinit
/usr/X11R6/lib/X11/xinit

Also, check if /usr/X11R6/bin is in your $PATH (echo $PATH)
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

RobbieCrashAuthor Commented:
find / -iname xinit results in:

/etc/x11/xinit
/usr/X11R6/bin/xinit
/usr/X11R6/lbi/X11/xinit

echo $PATH:

/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin
0
lynxlupodianCommented:
Probably /etc/X11/X does not exist. Check it and it's readability.

If it doesn't, first install you gfx driver - the nvidia one is closed source, so it isn't part of the distro (most probably). Then fix the /etc/X11/xorg.conf as the driver installation instructions say, reboot and retry.
0
RobbieCrashAuthor Commented:
How does one check somethins readability?

I tried installing the driver, but it told me it needed to build a kernel interface and then it couldn't find my kernel source, and I have absolutly no clue how to find it, or what to do once it's been found.
0
lynxlupodianCommented:
with readability I meant if it is readable (+r). You'd see it pe by "ls -l /path/file".
The first field lists the attributes in trios and r stands for readable, w for writealbe and x for eXecutable. First trio is the owner, second for his group and third for all other.
rwxr-xr-- #would mean you can do anything with it, your group can read and execute and others can only read


You need to install the kernel sources first.
urpmi kernel-source
0
RobbieCrashAuthor Commented:
kernel source 2.6-2.6.8.12.5mdk.x86_64 unsatisfied ncurses-devel

I'm assuming that means I should reinstall with all the developer packages installed and start from the beginning again?
0
lynxlupodianCommented:
i'd assume the same, install ncurses-devel and w/e else it needs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RobbieCrashAuthor Commented:
Dang, thanks.
0
rindiCommented:
can post the contents of /var/log/Xorg.log (only the last part, not the whole file)?
0
willy134Commented:
did you run the x setup i nthe mandrake setup (you have to manually do this at the end)  If not run

xfdrake
or later is is named
drakxconf

They should help get it set up.


0
RobbieCrashAuthor Commented:
There was no Xorg.log there, I don't know what that means but I can only assume it's not good.

I've tried running the X setup several times but it won't finish. After trying to reinstall again I realised that the iso I have for Mandrake doesn't have what I need to be able to install and that since I'm not part of Mandrake Club I can't download the images I do need to be able to install the 64 bit version and run a GUI.

Oh well, I'll try Debian instead.

Thanks for the help anyhow.
0
willy134Commented:
you can run mandrake 10.1 x86  ---not _64
it will run just fine....in fact not many linux apps are supported in x86_64 yet....

Good luck,
PS you can download community and then urpmi up to official. Either by waiting for the release or finding a mirror.

They have all the rpms out there just not the iso's
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.