[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 707
  • Last Modified:

IE 6 Never Opens A Page

Hi Everyone:

        I am having trouble with my stand-alone browser, IE 6.0.  Whenever I double click on it from the desktop, the following happens:  Instead of going out and contacting the server to a particular site, like google.com, it redirects itself back locally to res://c:\windows\system32\shdoclc.dll\dnserror.htm.  Interestingly, the integrated browswer of AOL 8.0 works fine.  I am only having trouble with IE is used as a stand along browswer.  I use AOL and Comcast to access the internet.  The OS is Windows XP Professional.  

        I have thought about using WinSockXP Fix and Internet Explorer Fix, but, I wanted to get everyone's thoughts on this concern prior to taking any troubleshooting actions.  

       In closing, I look forward to reading everyone's thoughts and suggestions on this post.

       Sincerely,

       George
0
GMartin
Asked:
GMartin
  • 4
  • 3
  • 3
  • +5
5 Solutions
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Download and install Spybot - I've seen Spyware cause this and Spybot can fix it.  I just don't remember the exact way - I'd start by immunizing IE and then scanning your system and fixing everything it finds (and turn off system restore first).  Spybot is available from www.safer-networking.org
0
 
blue_zeeCommented:

For sytarters, yes, try running this Winsock Repair for XP:
http://www.spychecker.com/program/winsockxpfix.html

Zee
0
 
sunray_2003Commented:
George,

I have seen winsock doing the trick right away though as you can read it says it should be used as a last resort.

If you are using Comcast connection , Try to use a different browser other than IE and AOL (if you have ) to see you get the same error. If yes there has been a corruption in winsock settings and you should try winsockfix.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
SheharyaarSaahilCommented:
George if your internet connection can be used under Safemode With Networking then try to open IE there with the Adminsitrator account.... if its working there then winsock is OK and there is some problem with the firewall or any other service running in background in normal mode...... and if IE is giving the same error there also then yes you should try the WinsockFix now :)
0
 
greyknight17Commented:
You can probably fix this with HijackThis.  Download HijackThis (http://www.greyknight17.com/spy/HijackThis.exe).  Create a folder at C:\HJT and move HijackThis.exe there.  Run a scan.  Look at the R0/R1 entries and you should see something with this in it: res://c:\windows\system32\shdoclc.dll\dnserror.htm

Just check those and hit Fix Checked.  See if that will fix it.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
I've got nothing against the other tools listed, but I've several instances where SpyBot corrected this problem.  Specifically, where IE always had the error described and where other browsers and internet applications still worked flawlessly.  (It should probably be run anyway).
0
 
way12goCommented:
Hit [ win key + r ] - run box and then type services.msc and then checkout what services are disabled. If the DNS client service is disabled [ Resolves and caches Domain Name System (DNS) names for this computer. If this service is stopped, this computer will not be able to resolve DNS names and locate Active Directory domain controllers. If this service is disabled, any services that explicitly depend on it will fail to start. ] or if the svchost.exe file is using the
CPU to a high level. Actually AOL is working fine means this can't be the error so it must be the IE registry settings or some files have been replaced with some older ones or might have been deleted. You can try windows file checking. Goto run box type gpedit.msc and then you can find an option for windows file checking at the next reboot at the startup and after the process is finished you can go back to the setting and disable it. There is also a command to run it when the system is running - current state
  ... two commands in this order, SFC /Purgecache followed by SFC /ScanNow Performing
these operations may take several minutes and will require your Windows XP ...

http://scscc.com/july/RunCommands.htm.
0
 
GMartinAuthor Commented:
Hi Everyone:

       Could someone give a description of exactly what winsock is about?  I assume it is a piece of software built within the OS which governs how data is sent and received across the internet, but, I am not sure.

       George
0
 
blue_zeeCommented:

Simple definition:

Stands for "Windows Socket"; software which enables Microsoft Windows application programs to do telecommunications using the TCP/IP protocol.

Zee
0
 
SheharyaarSaahilCommented:
0
 
OllienCommented:
To me it looks like the IE internet connection is just set up wrongly.  First confirm your internet access with another program.  Check you connection settings in Tools > Internet Options > Connections.

I'd make sure you have all that right before worrying about some other little program that may be causing an error, you will be looking for a needle in a haystack.

If all else fails, try uninstalling and reinstalling.

Reconfigure your internet connection.


Ollie
0
 
GMartinAuthor Commented:
Hi Everyone:

        Before I lead into the logistics which solved this problem, I want to extend my gratitude to each expert who participated within this post.  The numerous propositions to this question certainly laid the foundation for approaching the browser problem with self-assurance and confidence.  

        With respect to getting IE to open a web page, I had to perform the following procedures:  I had to open IE, go to Tools, then, Internet Options.  From there, I chose the tab Connections.  Once opened, I noticed there was a check mark by use proxy server along with an IP address which did not correspond to my wireless router address.  In any case, I unchecked use proxy server and placed a check mark by Automatically Detect Settings.  Everything else was left unchecked.  Then, I closed the browswer after reconfiguring the IE settings and reopened it.  To my pleasant surprise, the browser automatically opened google.com, the default page desired.  

        In closing, I want each expert to know I embraced each suggestion put forth within this thread.  Thanks so much for making available suggestions rich in content and application.  Without a doubt, this is only one of many cornerstones of EE which makes it constantly thrive.

        Very sincerely,

        George
0
 
blue_zeeCommented:

George,

Great news!

Thanks for the update.

Zee
0
 
OllienCommented:
George,

Very glad to see you fixed the ploblem, sometimes it can be something so simple!

It is great to see such appreciation for the work done around here, some people really work hard to help other people.  Thankyou for that.

Happy surfing,

Ollie.
0
 
SheharyaarSaahilCommented:
good job George :)
why dont you start participating in EE's questions..... ;-)
0
 
GMartinAuthor Commented:
Hi There:

       Thanks so much for the kind words.  I will give that some thought.

        George
0
 
SheharyaarSaahilCommented:
sure.... ^_^
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
  • 3
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now