: Problem

When I open a new file or edit an existing one it writes > instead :
No : in pascal ! ! ! How will I write programs?
Help!
The_BeemanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mlmccCommented:
I assume you mean when you hit the : key you get >
I also assume the : key works correctly elsewhere.

Have you run a virus check?

How do you start the Pascal?  Is another program/macro running first?

mlmcc


0
The_BeemanAuthor Commented:
You assume right, will do the virus scan then let you know if nother program(s) is running first
I start Pascal by klicking on the icon two times :)
0
For-SoftCommented:
Different (from english) language keyboards are capable of moving keys to different positions.
Maybe the : character has been moved to a different keyboard key location.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

The_BeemanAuthor Commented:
Did the virus scan an nothing. My language is Hr thats croatian.
I was able to write : in pascal a week ago and I can the language was Hr. Any sugestiones?
0
The_BeemanAuthor Commented:
And now I realized that I dont have the '
HELP I can't program like this!!!!!!!
0
For-SoftCommented:
You are working on english keyboard layout right now. Your Croatian keyboard support has been disabled.
The : character is in place of > caracter on english keyboard layout.
0
The_BeemanAuthor Commented:
I have solved my problem by myselfe.
 the : is in place of č and now I can type in the :
0
CentauriCommented:
You should change the dos keyboard language to english.
Anywhay you can use other languages in Windows, so you don't need the dos croatian language
0
For-SoftCommented:
I believe The_Beeman's keyboard has croatian layout (croatian labels on keyboard keys). The croatian DOS codepage was working before. Now he is working on english codepage. So, characters generated do not apply to labels on the keyboard.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Pascal

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.