NTLM Authentication in Tomcat Server

Hi,

 I've hosted my application in Tomcat.
I'm using NTLM Authentication.
The problem which I'm facing now is the server is not accepting POST requests.
Please help me in solving the problem.

Thanks in advance !!!
LVL 2
sujithkumars123Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rk_radhakrishnaCommented:
sujithkumars123,

using JCIFS we can do it.
This information may be usefull for developers like me ,

it is very simple 2 steps

1. download jcifs version xx.jar from the following link and install(copy) the jar into classpath of the IDE (server)

2 modify the web.xml with the following code, remember to put the code next to <display-name> entry
<filter>
<filter-name>NtlmHttpFilter</filter-name>
<filter-class>jcifs.http.NtlmHttpFilter</filter-class>
<init-param>
<param-name>jcifs.http.domainController</param-name>
<param-value>your IP address</param-value>
</init-param>
</filter>

In servlet or Action class use the following line to get the ID
request.getRemoteUser()

I have taken this message from this link so, it hope it may helps you
http://forum.java.sun.com/thread.jspa?forumID=45&messageID=2637226&threadID=503849
0
sujithkumars123Author Commented:
I tried this solution, but still the error is coming. I found that the browser is sending a no of headers. is there any way to remove these headers?
0
rk_radhakrishnaCommented:
I got the same problem when i was working with other problem, I removed header tag then I solved that.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

rk_radhakrishnaCommented:
try it..
header('WWW-Authenticate: Negotiate');
header('WWW-Authenticate: NTLM', false);
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sujithkumars123Author Commented:
Can u post the code used for removing the header tags, i tried setting authorization headerto "" but it is still keeping that same old value.

Thanks,
Sujith
0
rk_radhakrishnaCommented:
0
sujithkumars123Author Commented:
We had implemeted the same solution; then we switched over to jcifs filter;
We never found a solution for post parameters getting null;
Always the browser is setting Authentication header which causes the problem; we tried resetting headers which did not even work;
0
sujithkumars123Author Commented:
Solved the problem.
We loaded a JSP page, which is in a different directory, in a new window and did the authentication.
Then we closed the window.
Thanks for the support rk_radhakrishna.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
JSP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.