Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Set up Apache and Awstats - cgi-bin

Posted on 2004-12-01
10
Medium Priority
?
879 Views
Last Modified: 2010-03-04
Hi Experts,

can someone guide me on the set up of awstats via cgi-bin access?
Do I need to do any setting on my apache web server

Thank you
0
Comment
Question by:totoron
  • 6
  • 4
10 Comments
 
LVL 19

Expert Comment

by:ramazanyich
ID: 12733814
http://awstats.sourceforge.net/docs/awstats_setup.html
Check Part A: With Apache or compatible server (on Unix/Linux, Windows, MacOS...)
0
 

Author Comment

by:totoron
ID: 12771309
I tried but my http://www.domainname.com/cgi-bin/config=xxxx, it does work
0
 
LVL 19

Expert Comment

by:ramazanyich
ID: 12771482
what is the error messages ?
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 

Author Comment

by:totoron
ID: 12780607
The requested resource (/cgi-bin/awstats.pl) is not available.
0
 
LVL 19

Expert Comment

by:ramazanyich
ID: 12780788
but according config which is provided on that link (ScriptAlias /awstats/ "/usr/local/awstats/wwwroot/cgi-bin/" ) you should access it by:
http://www.domainname.com/awstats/awstats.pl?config=xxx
0
 

Author Comment

by:totoron
ID: 12781035
HTTP:404
Also the same error.

Actually one this web server, I have installed the tomcat connector.
Do you think it is actually go to tomcat?

Coz the error message that I get is
Apache tomcat 5.0.28 Error Report
The requested resource (/awstats/awstats.pl) is not available.

How to resolve this problem?
0
 
LVL 19

Expert Comment

by:ramazanyich
ID: 12781063
yes, It is redirected to Tomcat.
Check you JKMount directives.
Try to disable tomcat redirection first to check that it causes the problem, and if it the cause of the problem then check your JkMount directives.
0
 

Author Comment

by:totoron
ID: 12790105
How to set JKMount directives?
I did not set JKMount directory,I am using jk2 connector.
0
 
LVL 19

Accepted Solution

by:
ramazanyich earned 1000 total points
ID: 12790562
If it is jk2 connector then find in workers2.properties file lines that begin:
[uri:
and comment out that sections.
0
 
LVL 19

Expert Comment

by:ramazanyich
ID: 12790573
http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jk2/index.html
it is a installation and configuration guide for mod_jk
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
Loops Section Overview
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…
Suggested Courses
Course of the Month21 days, 4 hours left to enroll

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question