NT4 Stand Alone Servers DHCP

Hi

I've had a nt4 standalone server (lets call this one "AAA") running for a while now as a gateway (using comtun).  AAA is mainly used as an internet sharing device for my home LAN.  a hub is connected to the second nic on AAA and finaly, a few PCs are connected to the hub.  This is working perfectly, all the pc are getting the network configuration through the DHCP on AAA.  

Last night, I built a second nt4 stand alone server (that we'll call "BBB" (how original)).  When connected to the hub, BBB's NIC doesn't receive the network configuration.  At first I thought that the NIC was having a glitch but I connected the NIC directly to my cablemodem and I was able to surf the net.  I tried putting manually an IP address but then again it didn't work (well maybe I did an error on that part, it was around midnight).

AAA's second NIC is 192.168.1.1 connected to the HUB.  AAA is a DHCP server, DNS server and does SOCKS.

All help is appreciated!

- Nicolas
dohskyAsked:
Who is Participating?
 
stevenlewisConnect With a Mentor Commented:
I think the cable is not up to 568b snuff, or the NIC doesn't support 100mbit full. but usually in these cases it's the cable. Could be the hub, try a different port, but also try replacing the cable with a know good one
0
 
stevenlewisCommented:
first thought is the cable
cat5 568b specs?
what are you using to share the connection (NT doesn't have ICS)
enough leases in your dhcp scope?
0
 
cmsJustinCommented:
What services do you have running on BBB? Many services like DNS and DHCP dont allow you to have a DHCP address, and require static IPs for the servers.

-Justin
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
dohskyAuthor Commented:
Yep, the cable is cat5 and is working if i'm conecting a laptp.

DHCP scope is from 192.168.1.50 to 192.168.1.250 and I have 5 pc connected.

Comtun, used to be called Comsocks from Linkbyte is doing the ICS.  To what I know, it is doing a very good job.
0
 
stevenlewisCommented:
try forcing the NIC to 10mbit half (as a test)
0
 
stevenlewisCommented:
also try the static ip (make sure it's unique, and correct) and see if you can ping
0
 
FocusynCommented:
my two cents:

I would first try to connect BBB via a static IP (<50) as stevenlewis sugested.  Eliminate network connectivity as the issue, then go from there.  And you sound like you have a grasp on what you're doing there, but make sure subnet mask is 255.255.255.0 (or appropriate class C to match the others) and gateway is 192.168.1.1.

Also, what happens when you boot BBB and do ipconfig /all at the cmd prompt?
0
 
chefred112Commented:
what service packs on the Nt's?
0
 
dohskyAuthor Commented:
The NIC is working if i'm connecting it to my cablemodem (using the same cable).The hub is a 24 port all on autodetect.

I tried to set a static IP and still can't ping  (when pinging i'm requesting 192.168.1.1 and get request time out)

Here is the result of a Ipconfig /all
C:\>ipconfig /all

Windows NT IP Configuration

        Host Name . . . . . . . . . : amaretto
        DNS Servers . . . . . . . . : 192.168.1.1
        Node Type . . . . . . . . . : Broadcast
        NetBIOS Scope ID. . . . . . :
        IP Routing Enabled. . . . . : No
        WINS Proxy Enabled. . . . . : No
        NetBIOS Resolution Uses DNS : No

Ethernet adapter RTL80291:

        Description . . . . . . . . : Realtek RTL8029 Ethernet Adapter.
        Physical Address. . . . . . : 00-40-05-3E-4C-11
        DHCP Enabled. . . . . . . . : No
        IP Address. . . . . . . . . : 192.168.1.5
        Subnet Mask . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . : 192.168.1.1

I've installed the latest service pack and all critical updates..  sp6a I believe.

0
 
dohskyAuthor Commented:
Ohh  I might have found something...

If i'm connecting BBB to AAA 2nd NIC with a cross over cable.   It works.  And on the HUB,  it seems like BBB's NIC is doing 10mb, not a 100mb.

Soooooo  could it be the hub that screws up ?  Its a 24 port BayStack 252 10/100 HUB (It's only a hub, I don't have the "master" to configure it but usually, when no master is present, they are supposed to be on auto detect.

Any ideas ?

0
 
dohskyAuthor Commented:
I changed the NIC and tadam!!  

I just can't believe that for some reason, the hub can't stand slower connection.  Sounds wierd but I appreciated all your help guys!
0
 
stevenlewisCommented:
Glad it working!
0
 
FocusynCommented:
dohsky just FYI, if it's a managed hub, which it sounds like it is, often times the ports are configured for a specific speed, same way you can do with a NIC, and also most managed switches have the capability of converting particular ports to uplink, which basically swaps the contacts like a crossover cable.  I know you got it worked out, but just wanted to add that two cents for future reference.  You may have your ports staically set to 100 only etc...
0
All Courses

From novice to tech pro — start learning today.