• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 218
  • Last Modified:

emacs on feora core 2

I just intall fedora core 2 but anytime i am trying to open a file using emacs  =====> emacs myfile,
i am getting the the error message below. What could i do.
===================ERROR MESSAGE ===========================
crux:/afs/clarkson.edu/class/cs242/komlaaa/hw6/cd> emacs AbstractCd.java
Xlib: connection to "localhost:11.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
emacs: Cannot connect to X server localhost:11.0.
Check the DISPLAY environment variable or use `-d'.
Also use the `xhost' program to verify that it is set to permit
connections from your machine.
0
komlaaa
Asked:
komlaaa
  • 2
1 Solution
 
jlevieCommented:
Is the user you are when invoking emacs the same user that logged in? If that's not the case you'll see this error.
0
 
wesly_chenCommented:
Hi,

crux:/afs/clarkson.edu/class/cs242/komlaaa/hw6/cd> xhost +; emacs -d `echo $DISPLAY` AbstractCd.java

Wesly
0
 
wesly_chenCommented:
Hi,

   Is the issue resolved?

   If you use ssh from the Fedora Core 2 (A) login to other Unix/Linux box (B) , then make sure you enable ForwardX11
--- /etc/ssh/ssh_config ---
ForwardX11 yes

and ssh into FC2 (A) from other box (B), check
--- /etc/ssh/sshd_config ---
X11Forwarding yes

  The "xhost +" is run on the machine in fromt of you.
Say you are in front of FC2 (A), before you ssh into (B), run "xhost +" on (A) first.
Then
ssh -X <remote machine name or IP>

   Besides, remove ~/.Xauthority  at FC2 (A) and (B) then log out and log bcak in (.Xauthority will
be recreated).

Wesly
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now