I am configuring a Domino server to work with IIS, but I am using IIS 6.0, & I think the Domino documentation refers to IIS 5.0 - anyone know IIS well enough to help?

There are a number of instructions that don't make sense (you'll have to look in your own help file, or go to the URL):

To install the WebSphere plug-in on an IIS server

> 7. For access permissions, check and uncheck all other permissions.

What does that mean? I think this is actually just a typo, as there simply must be something missing. Anyone know what they should be set to?

> 10. On the "Internet Information Services" tab, select "WWW Service" in the "Master Properties" drop down box and click Edit.

There is no "Master Properties" drop down box in which to select "WWW Service" - has this moved somewhere else, or does it work differently now? I've tried adding this ISAPI Filter at the "Web Sites" level, rather than the machine name - will that do?

To configure the WebSphere plug-in

3. Add these directives to the top of the <UriGroup> section. These directives specify common URL patterns needed for accessing Domino Web applications.

<Uri Name="*/.nsf*">

Is this correct? Surely this needs the first * after the slash or something, doesn't it?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I think you have only a piece of whole setup..

Check this link: http://www-1.ibm.com/support/docview.wss?uid=swg21105816


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I recall a known problem using DOmno with IIS 6, which I think was supposed to be fixed in 6.5.3 and possibly 6.0.3.  Note that 6.5.3 has been reported as unstable.

Chec+uncheck may actually not be a typo.  It may be telling you "turn them on before turning them off, in case there are any that APPEAR to be off but actuall are not."

Master Properties -- very likely yes, the UI changed.  Can't really answer whether what you did is a good substitute, as I haven;t tried this on IIS 6, sorry.

On the last point, I think you are correct.  In 6.5, it changes this to:
       <UriGroup Name="default_host_URIs">
<Uri Name="/*.nsf"/>
<Uri Name="/icons/*"/>
<Uri Name="/domjava/*"/>
<Uri Name="/execcgi/*"/> etc.

PaulCutcliffeAuthor Commented:
Thanks HemanthaKumar, that document was basically an addendum to the instructions I was following, & boy, what an addendum! There were about six blatant errors in the instructions that stopped it from working altogether. Anyway. I've found it now, & now it's almost working!

I reckon the only difference between what I've done & what is written is that the ISAPI filter part is meant to be applied to the 'server' level in the tree on the left, whereas in IIS 6.0 it seems that you can only apply this at either the 'Web Sites' level or at the level of one of the actual web sites.

When I look at the ISAPI Filters tab of the 'Web Sites Properties' dialog (which is where I currently have the ISAPI filter configured), I can see that it is correctly configured, & has a status of 'Up'.

When I ask for a page from IIS, e.g. http://testserver.nettest.local, I get the default 'Site Under Construction' page from IIS, as I would expect.

When I ask for a page that doesn't exist on IIS, but does not trigger the filter (i.e. does not contain '.nsf', 'icons' or 'domjava'), e.g. http://testserver.nettest.local/webcounter, then I get IIS's custom 404 error page, as again I would expect.

When I ask for a page that does trigger the filter, e.g. http://testserver.nettest.local/webcounter.nsf, then I still get IIS's custom 404 error page, whereas I expect to get the Notes database webcounter.nsf if it exists, which it does.

I have IIS running on Port 80 of the host's only IP address, & Domino runs on Port 81 of the same address. The Registry entry (now named correctly according to the addendum) correctly points to my plugin-cfg.xml, which looks like this (& is in fact the default from the documentation):

   <!-- The LogLevel controls the amount of information that gets written to
        the plugin log file. Possible values are Error, Warn, and Trace. -->
   <Log Name="C:/WebSphere/AppServer/logs/native.log" LogLevel="Error"/>

   <!-- Server groups provide a mechanism of grouping servers together. -->
   <ServerGroup Name="default_group">
      <Server Name="default_server">      
         <!-- The transport defines the hostname and port value that the web server
              plugin will use to communicate with the application server. -->
        <Transport Hostname="localhost" Port="81" Protocol="http"/>

   <!-- Virtual host groups provide a mechanism of grouping virtual hosts together. -->
   <VirtualHostGroup Name="default_host">
      <VirtualHost Name="*:*"/>

   <!-- URI groups provide a mechanism of grouping URIs together. Only
        the context root of a web application needs to be specified unless
        you want to restrict the request URIs that get passed to the application
        server.  -->
   <UriGroup Name="default_host_URIs">
      <Uri Name="/*.nsf*"/>
      <Uri Name="*/icons/*"/>
      <Uri Name="*/domjava/*"/>

   <!-- A route ties together each of the above components. -->
   <Route ServerGroup="default_group" UriGroup="default_host_URIs" VirtualHostGroup="default_host"/>

Although I was still a little dubious about the "/*.nsf*/", I know this isn't the problem:

If I request http://testserver.nettest.local:81/icons/abook.gif, I get the icon from the Domino's icons directory.

If I request http://testserver.nettest.local/icons/abook.gif, I get IIS's 404 page, whereas the '/icons/' part of the path should trigger the filter & redirect the request to Domino.

I therefore believe it is just the redirect bit that isn't working.

Any ideas anyone? If not, I'm now convinced it's an IIS issue, probably because of minor differences between IIS 5.0 & 6.0, so I'll give qwaletee the points (for a change!) & repost the question into the IIS section.

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Correct me.. what ports are they listening ?
PaulCutcliffeAuthor Commented:
IIS listens on TCP Port 80, whilst Domino listens on TCP Port 81.
Silly question?  Why are you bothering with IIS for this?  The effort is similar to set up Domino alone, and just have it authenticate against your AD.
PaulCutcliffeAuthor Commented:
Because they want to host both IIS & Domino sites on the same single server.
That's funny.  Really, it is.  Because technically, it may be one server physical box, one IP address, and one hostname, but in reality, you are running two independent HTTP servers, and could even theoretically hit the Domino server directly on port 81.

If they aren't runing ASPs, or .Net apps, there's no real reason to use IIS at all.  And even if they are, there's really no particular reason to need them to share a host name.

Plus, you are going to be taxing the server more than necessary by running both on a single box.

For a situation like that, I'd much rather do a little reverse proxying.  You can even run IIS as the reverse proxy.  or, even simpler, have it redirect calls that look like DOmino calls to the Domino server.  So what if the URL changes.

But never mind, someone thought this was a great dea, and now, this is just the way it is going to be.  Good luck to you.
PaulCutcliffeAuthor Commented:
Sorry, I missed a bit. Originally, someone had the idea of wanting to combine IIS elements, like ASP & a Plugin, with elements from a Domino-served Notes database, within the same site & hostname etc.

However, I think discussions resulting from your comments have made them realise that they can easily do this by simply referencing a different hostname within the same domain.

This makes the config SO much easier, as you said, so I guess this question can now close! Yippee! Although it's a shame to get so close to getting something working & then give up on it, buy hey this is work, not a hobby! :-)

I shall be awarding 75 points to HemanthaKumar for pointing me to the updated instructions that (almost) got me up & running (it would have, had we not had IIS 6.0, I'm sure!), & a further 50 points to qwaletee for helping me talk them out of doing this altogether. Everybody happy?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.