remote client vpn access on a pix 515e

Posted on 2004-12-01
Last Modified: 2012-06-27
I set up our site to site VPN on our pix 515e and it works fine, but now I'm trying to add remote access vpn support with radius authentication.
Radius works for logging into the router via SSH so I know that it's set up correctly.
I get to the point on the client where it would normally prompt for username and password but it doesn't.
On the router the result of a show crypto isakmp sa is:
pix515(config)# sh cry isa sa
Total     : 2
Embryonic : 0
        dst               src        state     pending     created
   *.*.10.14     ***.***.252.9    OAK_CONF_XAUTH   0           0

Config below:

pix515# sh run
: Saved
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password ********** encrypted
passwd ************* encrypted
hostname pix515
domain-name *********.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
name dcnetwork
access-list inside_outbound_nat0_acl permit ip dcnetwork
access-list inside_outbound_nat0_acl permit ip
access-list outside_cryptomap_20 permit ip dcnetwork
access-list outside_cryptomap_20 permit ip
access-list outside_access_in permit icmp any any echo-reply
pager lines 24
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside ***.***.10.14
ip address inside
ip address dmz ***.***.10.17
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool
pdm location inside
pdm location dcnetwork outside
pdm location inside
pdm location outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0 0
access-group outside_access_in in interface outside
route outside ***.***.10.1 1
route inside 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (inside) host *************** timeout 5
aaa-server LOCAL protocol local
aaa authentication enable console RADIUS LOCAL
aaa authentication ssh console RADIUS LOCAL
http server enable
http inside
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set ESP-DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer ***.***.10.13
crypto map outside_map 20 set transform-set ESP-DES-MD5
crypto map rvpn 10 ipsec-isakmp dynamic dynmap
crypto map rvpn client configuration address respond
crypto map rvpn client authentication LOCAL
crypto map rvpn interface outside
isakmp enable outside
isakmp key ******** address ***.***.10.13 netmask no-xauth no-config-mode
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup remotevpn address-pool ippool
vpngroup remotevpn dns-server
vpngroup remotevpn wins-server
vpngroup remotevpn default-domain *********.com
vpngroup remotevpn idle-time 1800
vpngroup remotevpn authentication-server RADIUS
vpngroup remotevpn user-idle-timeout 5
vpngroup remotevpn password ********
telnet timeout 5
ssh outside
ssh inside
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username ***** password ************* encrypted privilege 15
terminal width 80
: end
Question by:frieked
    LVL 3

    Author Comment

    FYI I mean pix here not router
    ***On the router the result of a show crypto isakmp sa is:
    LVL 7

    Expert Comment

    Try adding these commands:

    aaa-server partnerauth protocol radius
    aaa-server partnerauth (inside) host x.x.x.x password timeout 10

    Where x.x.x.x is the IP address of your radius server and "password" is the radius authentication password that you set up on your radius server.
    LVL 3

    Author Comment

    I already have those lines:
    aaa-server RADIUS protocol radius
    aaa-server RADIUS (inside) host *************** timeout 5

    I just used the name "RADIUS" instead of "partnerauth"
    LVL 3

    Author Comment

    This line "crypto map rvpn client authentication LOCAL" was put in for testing and I have the same symptoms
    it should read: "crypto map rvpn client authentication RADIUS"
    LVL 79

    Accepted Solution

    You should not need this line when using the "crypto map rvpn client authentication RADIUS"
    >vpngroup remotevpn authentication-server RADIUS

    Reference doc

    LVL 3

    Author Comment

    Thanks guys, turned out to be a local problem with the VPN client, I reinstalled and it worked

    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Join & Write a Comment

    I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
    PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
    In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor ( If you're interested in additional methods for monitoring bandwidt…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now