terminal server access

One of the terminal servers on our network is not allowing nayone to connect to it. It was in remote admin mode, but now is in application mode. Since the change, that is when we started to have problems.

the error is this:

You do not have access to logon to this session

I have looked at the permission setting in the client config menu in TS config screen. I added myself as allowed to have full control. Also my login is an admin, anyway. This still does not allow me to login through remote desktop.

Then I looked at the group policy object for terminal services - and I enabled the 'allow users to connect remotely using teminal services'   But still cannot connect.

On local security settings - I am listed under the user allowed to login through terminal services. But still I cannot logon.

In all of that I saw no explicit denies.

The domain controller is 2000server. This particular terminal server I am having trouble with is 2003 server. On the domain controller I checked domain security policy, security settings, local policies, user right assignment - and it had no denies, but also does not have the selection for allow users to use terminal services.

I also added myself to the local machines group of remote desktop users. To no avail.

What am I missing? Why cannot a user connect to this server via terminal services? Every screen I can find says that I can connect.

I am about to give up and put this thing back to remote admin mode instead of application.




troyhicksAsked:
Who is Participating?
 
WeHeConnect With a Mentor Commented:
>It was in remote admin mode, but now is in application mode. Since the change, that is when we started to have problems.
This is not possible. There is no Admin mode in Windows Server 2003 Terminal Services.
If you have installed it, it will server you for free for 120 days. After that period it must have a terminal server license server with free licenses.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
troyhicksAuthor Commented:
both are usefull articles, escpecially the 2nd one. But if you had read my post - you would realize that I already set the permissions in GPO and in Terminal Services Configuration permissions.

I may just try to reboot this server and see ifthat clears it up. Since changing the license from device to user, I have not re-booted. Maybe it is hung up on that still.

0
 
cfairleyCommented:
Sorry, I couldn't be more helpful than that.  Pls post whether or not the reboot worked.  Also, what error messages are you getting in the event logs on both server and client?  The security log should show failure audits.
0
 
troyhicksAuthor Commented:
Huh? terminal services in remote admin mode does not exist in 2003? Ah, I see - I was confusing it with server 2000!

Well I was connecting to this server by remote desktop - but then decided to install terminal services (what I thought would put it in application mode). The reason was I ran into a problem with no more licenses available. So I thought it was more than 2 logon, as the problem.

So i wanted to put it in terminal services mode so that it will allow more users to connect - assuming they connect from XPpro and that works out as a license per user.

I installed terminal services, then switched to user instead of device.

Now i cannot connect? Where I could before.

I notice that the checkbox for remote desktop in control panel, system, remote - is greyed out.

I am now going to make this server a licensing server as well ... and see if that helps

0
 
WeHeCommented:
> assuming they connect from XPpro and that works out as a license per user.
You still need CAL's for all clients/users connecting to a W2K3 TS.
Builtin Licenses are not functionally under W2K3 TS, only on a W2K TS.
0
 
cfairleyCommented:
MSFT has a transition program if you purchased your clients before a certain date.  I answered this question a few days ago.  

http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_21222714.html
0
 
troyhicksAuthor Commented:
OK, the CAL's are for Server access - right? but the access to TS requires it's own licenses (which I understand are fulfilled by connecting from XPpro or 2000pro clients.)

I was going to install licensing server to see if that would resolve my problem - but could not as the 2003 disk was not avail at the time. So I uninstalled TS instead - now I can connect to the server again with remote desktop.

Though, still the check box for allow remote connections is greyed out?

Anyhow, this is not resolved. AS I found no reason why I was not able to connect to the terminal session after I installed terminal services. I do not believe it is a CAL issue.

This issue is about installing TS and then not being able to connect to it. And I have put in all the proper permissions - as per the instructions. All of this is documented in the above dialogue.
0
 
cfairleyCommented:
No problem Troy,

I do not know why the box is greyed out, but if you have been using TS for longer than 90 days or 120 day, I forgot which, you are going to need TCALs to connect.

Thanks,
cfairley signing out
0
 
WeHeCommented:
It's 120 days, i pointed to this a few comments before.
0
All Courses

From novice to tech pro — start learning today.