my outlook "Microsoft Exchange Server" account should NOT be the default

I am running outlook 2003 on Windows XP pro client under a Windows Small Business Server 2003 domain.

No matter how hard I try, microsoft exchange server keeps getting reset to be the default email account.

I'll manually reset it so that my outlook accounts look like this:

   Help@GreatService.com      POP/SMTP (Default)
   Microsoft Exchange Server   Exchange

Then, within 2 or 3 days, Exchange will sneak back to the top as default.  I can't figure out when or why. It does not seem related to reboot, going offline or send e-mail or anything I can pin down.

This is a big problem because I send dozens of e-mails every day, and 80% of them are supposed to use POP3 ISP  account and have return address of Help@greatservice.com.

Since the switch always occurs without my knowledge, my messages often end up as rberke@myDomain.com.  This confuses the heck out of my customers that receive the email.

The only solution I have figured out is to set up a second outlook profile that does not have the exchange serveraccount.t. When I want to use the exchange account, I close outlook and restart it with second profile, send the message, close outlook and reopen with standard profile.  Ugh!!!

This is a new SBS 2003 installation.  The problem has occurred since I started using Exchange about 4 weeks ago.  I did similar things on a SBS 2000 installation and I don't recall having this kind of problem.

HELP!
LVL 5
rberkeConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rhandelsCommented:
Hi,

You can also try to create two different users in AD, make sure to give the help@greatservice.com permissions to send as rberke@MyDomain.com and make sure to add the from field (is in the view menu of Outlook) and send ail as rberke@.. when logged in as help@greatservice.com..

0
rberkeConsultantAuthor Commented:
I believe your proposed solution would require connection to the server in order to send emails. I forgot to mention that I am using a laptop which is often not connected to the server. That's one of the reasons I want my default account to use the greatservice.com ISP SMTP server.

Other than that, your solution would make sense.
0
rhandelsCommented:
Darn, this makes thing a bit more complex.. I'm not wonrking that long with Outlook 2003 and only use the Exchange part. Maybe the problem is within your roaming or local profile.. Do you logon to the domain and locally?? So do you have two users on your laptop, one for the domain and one for the laptop?? Maybe the profiles of the users get mixed up and the settings are being changed..

I also thought that you need to be a local admin to change these permissions, might just help, some extra info..
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

MicrotechCommented:
exchange server, I believe is always the default, the option they have given for this senario is the accounts button, which needs to be changed every e-mail, (which is painful I know), I have tried this many times and it always defaults back to exchange server unless the e-mail you are replying to has come from your isp account.

http://office.microsoft.com/en-us/assistance/HP052426321033.aspx 
0
rberkeConsultantAuthor Commented:
Microtech: You say you have tried this and "it always defaults back to exchange server".  In your experience does this default back to exchange occur immediately, or does it occur randomly sometime in the next 3 days?

By the way, the link microsoft.com link implies that any account can be used for the default, which is exactly what you are saying DOESN'T happen.

rhandels: This has happened on 2 other laptops, and 2 desktops.  All use Windows XP pro at Service Pack 2.

I originally set up 3 laptops and 4 descktops with exchange NOT the default. Before I realized what was happening, 5 of them had received this problem (not all on the same day or time.) Most of them are dedicated computers with one user who always signs on directly to the domain and never disconnect (except for the nightly shutdown). Nobody logs on locally. Once I realized these people were sending e-mails using the wrong return address, I disconnected everybody from exchange except for me.

I'm the one that got us into this mess, so I am the one that will suffer until I get us out of it.

I understand that the desktops could avoid the problem by using the solution you described in your first post, but it will not work for the laptops.  I am hoping for a single solution that will work the same for all users.
0
rhandelsCommented:
So my guess was way off... This problem must be within Outlook... Maybe you could try and demote to Outlook 2000?? I do believe it can be done using Outlook 2000 (did see a some info on this)...
0
rberkeConsultantAuthor Commented:
ARGHH!!  i hope not.  I hate telling my boss that I have to go back to old version only 4 weeks after going to the new version.  

Lets see if anybody else has any bright ideas.
0
rhandelsCommented:
I do hope so....
0
MicrotechCommented:
the link i put you to was for outlook 2003 without a connection to an exchange server sorry, should have said. In my experience it happens when the program is restarted I believe, but it is workable using cached mode and the accounts button on the individual e-mail. just a pain to click each time.

It presumes that your account with exchange server will win priority no matter what. Or at least that is my knowledge after researching. I will try and dig out what I found.
0
rberkeConsultantAuthor Commented:
Program restarting does NOT cause reversion at least for the 5 clients in my domain where I have tried it. In fact rebootin does cause the reversion either.

I have found NO documentation that implies Microsoft intended that exchange will always revert to the default.
 
If someone finds such documentation, I will immediately call microsoft and report a bug, because it sometimes takes 3 days for exchange to revert to the default.

I would call them now, but it costs $250 for tech support on server based products
0
rberkeConsultantAuthor Commented:
I now understand 99% of what is going on.

I can get this to repeat.  I have two user profiles
   RBerkeWithNoExchange
   RBerkeWithExchangeAndOthers

When Outlook launches it highlights RBerkeWithNoExchange before asking which one to use.

with that configuration, logging off and back on did NOT reset Exchange to the top.

I changed the configuration so that Outlook highlights RBerkeWithNoExchangeAndOthers before asking which one to use.

Now logging off and on back on DOES reset Exchange to the top.

 

At the microsoft partner small business server 2003 forum, I found a post which explain things.

It doesn't mention it, but the the application launcher appears to only adjust the highlight profile, and does not touch the other profiles.

begin of forum posting ---------------------------------------
This is an expected behavior in SBS 2003 environment.

The first line of the logon script SBS_LOGIN_SCRIPT.bat calls Application Launcher
on RBerke's sbs2003 this is  \\SERVER02\Clients\Setup\setup.exe /s  MYSERVERNAME
but the forum post said it is Program Files\Microsoft Windows Small Business Server\ClientSetup\Clients\Setup
\applnch.exe

Application launcher adjusts the Outlook transport order to set Exchange as the default type.

Therefore any changes are undone when you logon the next time.

If you don't want your changes to roll back, you can try *either* of the following methods (the latter is
recommended):

1. Stop the logon script running for the user account you use. You don't have to delete the logon script, simply go
to Active Directory Users and Computer, open the Properties of the account and remove
SBS_LOGIN_SCRIPT.bat from the Profile tab.

2. At the client, create the following registry value:

Location: HKLM\Software\Microsoft\SmallBusinessServer\ClientSetup
Name: NoTransportOrder
Type: REG_DWORD
Data: 1

end of forum post ----------------

Personally, I am trying a third option which is

3. Change the first line of the login script to say "REM \\SERVER02\Clients\Setup\setup.exe /s  MYSERVERNAME"

Very little else is on the internet about NoTransportOrder.  Here is one quick article.


http://seanda.blogspot.com/2004/10/having-trouble-trusting-exchange-from.html

0
rhandelsCommented:
Looks like a good solution to me... This guy does make sense anyhowes...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rberkeConsultantAuthor Commented:
After more research and some help from Microsoft Partners small business 2003 forum, I decided NOT to REM out the line that says    \\SERVER02\Clients\Setup\setup.exe /s  SERVER02

Instead, I created a new file in the same directory with my login script.
C:\WINDOWS\SYSVOL\domain\scripts\use NoTransportOrder.reg
      [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\smallbusinessserver\clientsetup\]
      "NoTransportOrder"=dword:00000001

Then, I added the following line to my SBS_LOGIN_SCRIPT.bat  
      regedit /s "use NoTransportOrder.reg"

It automatically installs the desired registry value when someone logs in.

This is a better solution because the setup.exe does quite a few things. I don't really understand them, but they sound like they are worthwhile.  Here are some of the things it setup.exe does.
" Validates the requested IP address
" Adds it to the SBS Servers OU
" Specify a static IP & subnet mask (which server, if any is DHCP is also covered)
" Validates the requested static IP address
" No profile migration to the server will occur
" Connected printers will be published in the SBS AD
" Install tsweb activex control so tsweb will work for all ts clients.

It seems to be working, so I'm rolling it out today.  If it works properly, I will close this problem by the end of the week.



Bob
0
rberkeConsultantAuthor Commented:
Notransportorder works pretty well, but it turns out there is a "design feature" that is causing me problems.

Notransportorder cause most of my e-mails to automatically go out from help@greatservice.com but there are two exceptions:

If I reply or forward a message that was sent to me at rberke@mydomain.com, my reply will be from rberke@mydomain.com.  This feature is very good, and makes total sense.

If I reply or forward  a message in my Sent Items mailbox, my reply will automatically be from rberke@mydomain.com.  
This makes no sense if the original message was from help@greatservice.com.  I can override it manually, but I keep forgetting.

I have opened a trouble report with microsoft.  After spending over two hours on the phone with a knowledable technician, we came to the conclusion there is no way around it.  The technician is sending a note to the Outlook design team, and perhaps it will be fixed sometime.  Until then, there is no reasonable work around.  Other people might be able to use different login profiles to solve the problem, but it won't work for us.  

I will try to train my users to be careful when replying to something in Sent Items mailbox.  I'm sure they will forget, but what's a fellow to do?


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.