• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 245
  • Last Modified:

double connection problems

HI,
I have the following two problems with connecting the mac to the network.
1- when I use LAN connection at work, it is not acquiring the IP address automatically, and since it is very late now, there is no one to help with assigning an IP address for me. I have just switched to Mac, and i have heard many good things about the mac networking capabilities, but have seen none so far. I connect my old Notebook, and it works fine, but not the PB. At home when I connect to my router through the cable, it acquires all the information automatically. Can some one help, please?

2- at home my router is also wirless, I get the connection to the network but I cannot access the Internet?

thanks for the help
0
MMsabry
Asked:
MMsabry
1 Solution
 
BaconManCommented:
I seem to recall some occasional issues with Panther and DHCP servers.  I can't recall the particulars, however, but it seems you've been bit by that (relatively rare) bug.  One thought: Is this network a domain or a simple workgroup?  There may be security settings on your domain-based network that will prevent your computer from fully logging on.  That said, you can probably get yourself connected temporarily, to the internet, if not the corporate network, if you connect your old laptop, note the IP address assigned, and plug those numbers into your Mac manually.

Can you access network shares at home?  Make sure your mac is pulling an IP address from the router... I've seen situations where it looked like you were connected, but weren't fully authenticated to the wireless router, so the connection was effectively dead.  Also, open a terminal and ping yahoo.com to make sure you are connecting and pulling a DNS server.  If you can't, ping Yahoo from your PC, note the IP address, and ping the raw IP address from the mac.  If you can ping the IP, you are connected, but the DNS info is not working properly.  Hard-coding it should fix it, in that case.
0
 
MMsabryAuthor Commented:
thanks, i have solved the problems,
1- at work, i needed to supply my mac address, and it works fine now

2- at home, it took some time, but i figured it out in the end. the problem was that my router can have 4 wep keys, although i have set it up for the second key, the mac was only able to connect when i used the first key.
so that was it.

thanks any way
0
 
OzzModCommented:
Closed, 500 points refunded.
OzzMod
Community Support Moderator
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now