• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 231
  • Last Modified:

WindowsME USB ZIP 250 device=seen, no drive letter assigned

Gentlemen,

I have been presented with a Windows ME computer with the original symptom of hanging and being generally unresponsive, but after a fresh restoral of the Windows ME operating system, the USB attached ZIP 250 drive is not being seen when connected.  It is reported to have worked fine before.

I can see the zip device in the device manager fine.  And when I unplug it, the entry is removed from the device manager list, and the OS complains about a USB device being spontaneously ejected and may cause instability.  Also, I can hear the drive spin up when it is connected.  Btw: this is a USB powered drive, not something with an external power brick.

However, there is no presentation of the drive in the Windows Explorer.  Having a disk in the zip drive makes no sense.  There is no drive letter being assigned for this drive.

I have downloaded the latest and greatest driver from the Iomega website, the file size is 8.4 megabytes and is called: "ioware-w32-x86-402".  I have installed this before attaching the device and after, and uninstalled, and I've installed the original cd which came with the zip drive, with many reboots along the way.

From what I can see, the OS is seeing the device fine, but somewhere along the way, the OS is forgetting to do that last, most important step of assigning a drive letter to the drive device and normalize things.

To rule out whether the drive works or not, I've connected it to my notebook computer and the device was discovered promptly, correctly, and I can browse through the directory of data file.  So it isn't the drive.

Anyone have any suggs on what I might be overlooking?  Perhaps some insight into the steps involved in having a disk of type USB come and go, and act like a conventional disk with a drive letter.


0
ChrisEddy
Asked:
ChrisEddy
  • 5
  • 3
1 Solution
 
blue_zeeCommented:

1. Bootup in Safe Mode and check Device Manager for "obsolete" entries for that device (or similar ZIP's) and delete them.

If you found them, reboot and the problem should be solved.

2. What motherboard (brand and model) is installed? You may need a driver update for the motherboard.

Zee
0
 
ChrisEddyAuthor Commented:
Thank you for responding quickly!

I can reboot and check for obsolete devices.

However, I think I've ruled in the problem is related to USB support by the Windows ME operating system, rather than a device incompatibility.

I did this by connecting a digital camera device to the computer via USB, and the camera is not being seen as a disk device or as a usb device.

The computer is a gateway desktop.  There is no further identification on the outside of the box other than the serial number, but System Properties shows that it does have a P4 processor and .25G of memory, for what it's worth.

Ack on the possibility of the mobo fw update.  I'll look into that.

0
 
blue_zeeCommented:

Maybe aortha try: after booting up in Safe Mode delete the USB controllers in Device Manager and reboot (you may need the WinME CD).

You can also download and run Everest Home Edition to identify your hardware:

http://www.lavalys.com/products/download.php?pid=1〈=en

This utility will also give you the links to update the drivers!!

But, do try first removing the USB controllers and reinstalling upon reboot.

Zee
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
blue_zeeCommented:

Maybe worth a try:...

Sorry, fat fingers.
0
 
ChrisEddyAuthor Commented:
News ...

The digital camera device that was not seen is being seen now.  The difference: press a long and unlabelled button, which causes the "P ASM" light to flash on the camera.  So not only does the camera have to be turned on (check), and the docking cradle has the power plug securely pressed in (check), and the mode button has to be in the right position (check), there's this.  

A minor cognitive disconnect was that after the camera's USB plug was connected to the computer, and the device was indeed seen once the long and thin button was pressed, the camera was presented in My Computer as a device of it's own type, rather than an F: drive or something disky like that.

When the USB plug to the camera is removed, the flashing light stops flashing, and the camera device promptly goes away in the My Computer list of devices.

Btw: I tried to reflash the bios, confirming that the reflash is indeed targeted for this bios - and it is, and it failed because the source file was corrupt.  Jeez ...


0
 
blue_zeeCommented:

I wouldn't play too much with flashing the Bios (you may be calling for trouble).

Try removing and reinstalling the USB controllers and if that doesn't do it try identifying the motherboard with Everest to locate updated drivers for it.

Zee
0
 
ChrisEddyAuthor Commented:
More news ...

The unstable operating system was reinstalled, digital camera, the zip drive, the scanner, and the Kodak easy sharing software all work now.

The reinstallation of the OS was something other than straight forward, more like a secret handshake.  The bios needed to have the CD drive added as a bootable device that comes before the hard drive.  The first recovery disk is bootable, but it must be inserted into the first CD drive, which is the top one. Using the bottom drive for disk 1 and the top drive for disk 2 will endlessly report a missing file.  The second recovery disk is the one that contains the operating system.  The third one contains the low level software, such as for the mobo chipset, plus some applications.  One down.

After the installation, there was little or no networking work to do, since the equipment upstream (LinkSys hub/ wireless access point, Morotola cable modem) was serving DHCP just fine.  Two down.

All of the operating system updates were applied, antivirus software was downloaded and installed and updated, plus some other software that I believe is essential.  Three down.

The problem with the digital camera was solved as described above.  Four down.

The problem with the Zip drive not working was caused by there being an apparent differentiation between the driver software and the application software.  After the drivers were downloaded, installed, and the computer rebooted, the Zip drive was seen with zero drama.  Five down.

The scanner is a new thing added to the mix at the last moment.  Actually, the box had been on the desk during the entire troubleshooting session, but I was too focussed on solving the problems being presented, and overlooked the scanner.  The fact that the scanner was on the far rear corner of the other desk and had papers on and near it may have contributed to my overlooking it.  There was one problem with the installation that caused a folder not found error to be displayed when clicking on any of the buttons relating to scanning.  Creating that folder was the solution.  Six down.

We decided to play with fire and tried the Kodak EasyShare software.  Before this troubleshooting, this software would consistently cause the computer to hang.  Let's just say that it's mojo was definitely *not* rising.  Seven down.

I walked my customer through the entire process and confirmed that all things worked well, and my general impression was that he was going to be reasonably happy with the way things turned out.   Eight down.

In all, it was a long day.  But all of the problems he was having were solved.    Thank you!


0
 
blue_zeeCommented:

Great news.

And well done.
:)

Zee
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now