Link to home
Start Free TrialLog in
Avatar of TimLaL
TimLaLFlag for United States of America

asked on

K_MODE_EXCEPTION_NOT_HANDLED

I see that this is not a unique issue, but so far I have been unable to resolve it on this workstation.
Whenever we attempt to open Wordperfect Office 11, or run MS Word 97 for any length of time or use notepad, we get this exception error.  

I get different addresses depending on the program.With Wordperfect, I get "*** STOP: 0x0000001E (0xC0000005, 0xBB5BE775, 0x00000001, 0x00000000)"  followed by the K_MODE_EXCEPTION_NOT_HANDLED, address ........ etc.

With Word 97, the error is:
"*** STOP: 0x0000001E (0xC0000005, 0xBC1F1775, 0x00000001, 0x00000000)"  followed by the K_MODE_EXCEPTION_NOT_HANDLED, address ........ etc.

Outlook seems to run,
All W2K updates have been applied,
I've scanned for viruses using Norton Antivirus 2005 (as part of Norton Internet Security)
Suggestions would be appreciated!
Avatar of night_monkey
night_monkey
Flag of United States of America image

could be a hardware problem. boot to recovery console and do a scandisk.

Starting the Recovery Console
To start the Recovery Console, use either of the methods described below:

Start your computer with the Windows 2000 Startup (Setup) floppy disks or with the Windows 2000 CD-ROM. At the "Welcome to Setup" screen, press F10, or press  r  for Repair and then  c  to start the Recovery Console.


Add the Recovery Console to the Windows 2000 Startup folder by using Winnt32.exe with the /cmdcons switch:
  wintt32.exe /cmdcons
This requires approximately 7MB of disk space on your system partition to hold the cmdcons directory and files.

Use this command:

chkdsk C: /F


You should also check your memory. You can have the BIOS do a memory test during POST or you can download a tool.
Here's one:

http://www.simmtester.com/
I believe the instruction address 0xBC1F1775 is within your display card driver. If you can attach the minidump and I can confirm the failing module. You can find the minidump at \winnt\minidump.

BTW what display card are you using. Did you upgrade W2K to SP4 recently?
Avatar of TimLaL

ASKER

I have yet to run the scan disk per your instructions but haven't gotten all the way through the installation of the recovery console as yet.  When I got to the point I thought I had it all installed, then attempted to run chkdsk C:/F, I kept getting an error that the /F parameter was not recognized.  When I run it just as "chkdsk C:",  I get a message telling me all is OK.


Thanks for the heads up on simmtester.com.  We downloaded their memory doctor and are now running it on the machine.

At one point in setting up the memory tester program, I went to print out their e-mail instructions and ended up locking  up the machine again.  
I got essentially the same error message with one address different:  it appears that all the addresses stay the same except the address of "0xB****775".  
On the Wordperfect lock up, that address was 0xBB5BE775
with Word it was 0xBC1F1775
with the print crash: 0xBB51E775
Does that help at all?
Well, to me it still seems like a hardware issue. what did the memory test reveal?
Also, to get the list of available switches from a command line you can do something like this:

chkdsk /?

it will give you a short description of the command and its switches.
I'm still waiting for you to attach the minidumps. If I have the dump, I can find out the culprit.
Avatar of TimLaL

ASKER

Ran the memory test through several passes (over a period of several hours) --- no failures.


Ran chkdsk, no problems found or fixed.

Other than a modem card (not connected to a phone line at the moment), the Video card is the only other "daughter" card plugged into the mother board (besides two RAM DIMMS).
Video card is a 32MB GeoForce 2.

I'm going to power down, unseat/ reseat any thing that plugs in and try again!
Avatar of TimLaL

ASKER

OK, did all the above, no change in crashes.
Powered back down, pulled both 256 MB/ PC 100 DIMMS and installed a "spare" 128 MB/ PC133 - restarted, same crash, different code/ error in the one address location we've been watching OxB****775, and got a OxBC104775 address with the following: address BC104775 base at BC0F0000 date stamp 3a7780c8 Pwgdi.dll.

Went back & pulled out the
Avatar of TimLaL

ASKER

Ooops, finge hit the return  on previous,
Anyway,
went back & pulled out the 128 MB PC133 DIMM, reinstalled the original two 256 MB/ PC100 DIMMS, restarted, tried to crash again, and did ..... successfully lock up,
Got the "memory dump" blue screen,
the address location now reads OxBCOB6775
followed by - address BCOB6775 base at BC0A2000,  and the same date stamp & dll
If you don't want to attach the minidump at the webspace
Disable auto restart
Right click My Computer>Properties>Advanced>Startup and Recovery Settings and uncheck Automatically Restart.
When BSOD occurs, windows will freeze at the blue screen and you can see failing module if it is not within ntoskrnl.exe.
However the failing module may not be the culprit and the minidump has more information.

Hope it can help you.
cpc2004
If the failing module is w32k.sys is also not a culprit as w32k.sys is the core component of W2K and it is unlikely it is the culprit.
If have  Minolta 1100L, read this webpage http://www.driverforum.com/printer4/3386.html

Avatar of TimLaL

ASKER

Sorry, forgot the minidump.
I'm not at the office, so not with that machine.  I'll send it next opportunity.
Avatar of TimLaL

ASKER

I don't know how to attach the minidump file.  I thought I could open it in Windows Expolorer and attach the text, but Windows can't open it.  Help?
You can find my email address at my profile.
I've studied the minidump and I confirm that the driver of  Minolta 1100L printer is 3 years behind and it is incompatible with W2K Sp4.  Refer  http://www.driverforum.com/printer4/3386.html

You can download the upgraded Minolta Printer drvier at http://www2.driverguide.com/uploads/uploads21/22949.html

BugCheck 1E, {c0000005, bc217775, 1, 0}
Probably caused by : Pwgdi.dll ( Pwgdi+14775 ) <--- culprit
Pwgdi.dll    Wed Jan 31 11:04:40 2000 <--- 3 years behind

Hope it can help you
cpc2004
Avatar of TimLaL

ASKER

Very many thanks!!!
This has done the trick.  I now have a happy partner who has a happy wife.  
Good work!
ASKER CERTIFIED SOLUTION
Avatar of cpc2004
cpc2004
Flag of Hong Kong image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial