Link to home
Start Free TrialLog in
Avatar of novaj9
novaj9

asked on

No Drive Attatched to Fastrack Controller/Asus A8V Problems

I know this question has been answered elsewhere on this forum before, but I seem to be having a bigger problem that those solutions won't fix.  Here's my situation:  I'm building a new system and I've got everything installed fine, the system turns on and does a system check.  It shows that my Maxtor 200GB SATA HDD is attatched to SATA Port 0, but when it scans for IDE drives during the system test it comes up with the "no drive attatched to fastrack controller - no bios found".  My setup is this:

Asus A8V Deluxe MOBO
Maxtor 200GB SATA 7200RPM HDD
Corsair 1GB RAM
AMD Athlon 3200+

I've tried all of the solutions I've seen here including: 1) Going into the bios and disabling the fasttrack controller 2) enabling the fastrack controller, but making it IDE instead of RAID 3) setting the system to boot of off the CD-ROM with the Win XP disc and then when it asks for RAID drivers I hit F6.  A little while later it will ask me for a driver disk and when I put it in it checks the disk and then continues to ask me for a driver disk.  In other words it doesn't seem to recognize any other driver disks as being the right one to install the drive.  I've downloaded every available driver I could find from ASUS' website and none seem to work.

So, I'm at the end my rope.  I don't know if I should go out and buy another HDD so it will finally recognize it as a RAID config, or if my motherboard is actually fried  and I need to send it back and get a new one.  It doesn't seem fried to me as everything else seems to be working fine, but I have no idea what else I can do here.

If anyone could give me advice on this I would REALLY appreciate it.

Thanks
Avatar of MadAd1
MadAd1

Urm, you dont say wether anything IS actually connected to the FT PCI IDE controller - Im assuming something is since if it was blank then you couldn't be too surprised about getting that error back :)

I dont see why having just one device on the FT would cause a problem, however I have to set my bios boot settings to SCSI for mine to be recognised (TX2 & TX2000).  Im sure youve tried that, but if not, do so before you post back.
Avatar of novaj9

ASKER

I'm sorry, but what do you mean by "FT"?  My SATA drive is the only HDD in my system right now and it's connected to the SATA 0 Port.  I have my CDROM connected to the secondary IDE connector, but that's it.  I don't believe I have the option in my boot settings for SCSI.  It's either IDE or RAID.
Oh and of course go through the no brainer stuff too like:
checking the firmness of the IDE connections,
make sure that any single IDE devices are on the end connector of the ribbon (not the middle),
make sure your FT has actually been set up in its own bios (ctl-f) for whatever config of IDE drives you have (option1 is probably easiest, autoconfig, but if having problems, try manual setup (3) set to spanning),
your drive has its jumper set to master and is plugged to IDE Channel 1 on the FT
ohhhh, my gawd I need a break, im reading your problem as having an additional fasttrak (FT) controller as well as the SATA .... now I understand- Doh!
Avatar of novaj9

ASKER

Yeah I was wondering what you were talking about :)  Any ideas?
ASKER CERTIFIED SOLUTION
Avatar of crazijoe
crazijoe

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
You cannot RAID with just one HDD.
Try entering BIOS and:
1) Set the OnBoard Promise controller to Disabled (in "Advanced" section).
2) Set the OnChip SATA BootROM to Enabled (in "Advanced" section).

Save changes, reboot, turn off and connect your SATA drive to the connector that says so i.e. "SATA1", and do NOT use the "SATA_RAID1" or "SATA_RAID2", since you disabled them from BIOS.

Enter BIOS again and make sure that the Boot Device Priority is properly configured (in "Boot" section) to point to your SATA1 connected drive. Save and reboot.

At this point you will not be prompted to insert a disk with a driver for WinXP installation and it will run without problems, but if you need to load a driver, as Crazijoe says above, load the VIA, not the Promise driver.
Avatar of novaj9

ASKER

Hey crazijoe thanks for your answer.  After reading your response I figured out what the problem was:  my floppy was bad.  I ran out and got a new one, downloaded the SATA drives and BAM, it worked.  So, even though it was a hardware malfunction, your answer was spot on!  I was pretty confused about the whole promise/fasttrack thing, thanks for clearing it up.

Thanks,
novaj
Not a problem. Thx for the points.